PDA

View Full Version : Image Lighting



starrliteangel
08-19-2005, 07:44 PM
I put the image lighting script on my website, www.geocities.com/xxshinshidoumeicrossxx , but it doesnt seem to be working. I put it on the avatars before each of my updates. they worked only once continuously, and now they briefly flash once. how can i make it go continuously? i dont think its my computer because I can see the demos.

jscheuer1
08-19-2005, 10:18 PM
None of it appears to be working just now. Does it work locally for you? If so, here is something that may be helpful:

Geocities (as are many free hosts) is a poor hosting choice when you are planning on using much javascript. Free hosts generally, Geocities in particular, put many of their own scripts on your page automatically when you upload them. These scripts often conflict with some or all of your own scripts on your page rendering them nonfunctional or dysfunctional. The real test is, if it works locally but, not on Geocities, it could well be script conflicts, there are other possibilities. Two of the biggest conflicts arise when your script uses i or j as variables (Geocities hi-jacks those for its own scripts) or if your scripts attempt to put offsite material inside a frame or iframe on Geocities (they've got scripts designed to prevent that). In the first case you can change all i's used as variables to other more complex variable names, same with j's but, of course, use a different name for all the j's used as variables. The second problem has no work around that I know of.

starrliteangel
08-20-2005, 02:32 PM
what do you mean by locally? i understand everything else you said. hm..what about cjb.net? do you know if any of their scripts will interfere with the lighting effect?

jscheuer1
08-20-2005, 03:25 PM
Locally, for some odd reason I thought that might trip you up. I meant on your own computer. You do have local copies of your page(s) on your own hard drive, right? If so, does the effect work there?

Now you get to trip me up as, I've never heard of cjb.net. I just logged on over there and from their faq I wasn't able to tell. If you have an address of a free site on their system, I can take a look. They probably do. When working with free hosts, one usually must work around the host added scripts or skip using a given script if it will not work on the free host.

starrliteangel
08-20-2005, 03:55 PM
actually, i just tried cjb.net and i think its working. the url is www.tenshi-no-uta.cjb.net. the only thing is, cjb.net seems to have something wrong with it or they encoded something in my page that makes it redirect to cjb.net.

starrliteangel
08-20-2005, 04:00 PM
o, and yes, it does work locally

jscheuer1
08-20-2005, 04:25 PM
If it works locally, it probably is the host. I'd stay away from cjb.net. They seem to be trying to install some adware (or worse) on my system.

starrliteangel
08-20-2005, 05:00 PM
alright. thank you very much for the help!