PDA

View Full Version : All Levels Nav Menu 2.1 - How do I center the nav?



evanmiller2007
05-12-2009, 07:56 PM
1) Script Title: All Levels Navigational Menu (v2.1)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/ddlevelsmenu/index.htm

3) Describe problem: Hi guys! I'm really sorry if this is a stupid question or one that gets answered a lot, but so far I just can't figure it out. Basically, I'm trying to make it so that the menu buttons for this nav are centered on the page, with gaps in between them so they aren't all clumped together. Here is what I have so far:

http://www.webworkscorp.com/h3tg/nav/

As you can see, the menu buttons are all aligned to the left. I want them to be centered and spanned out, like this:

http://www.webworkscorp.com/h3tg/ (you can ignore the dropdown menu on that, the client doesn't want to use that).

Is there a to do this in the CSS? I had a few ideas to fix it, but they aren't ideal- mainly just putting a bunch of spaces in to span them out, or putting in blank white image files. That might work but I'd rather do it the right way.

Any help would be appreciated! Let me know if you need more info.

edit: note to the Mod: sorry if there was confusion, but I actually didn't resolve this myself (I thought I had, but I didn't).

evanmiller2007
05-12-2009, 09:32 PM
i posted this a little bit ago and then removed it because i thought i had figured it out, but i guess i haven't.

i'm still looking for an answer to the above question (I made a temporary fix for it for now, by adding blank white images to span things out. Is there a better way to do this?

second question:
when using firefox, there seems to be a small gap below "Services" and above the rollover menu. When I rollover "Services", the menu pops up... but then when i start to move my mouse towards the menu, the second i hit that gap the menu disappears. this doesn't happen in IE7.

i changed the "hideinterval:" code in the ddlevelsmenu.js file to a higher number- from 200 to 800. this adds a delay before the menu disappears onmouseout, which works. The problem is, it doesn't seem to make any change to the menu disappearing when my mouse hits that gap. the menu still disappears the instant my mouse moves out of the "services" box.

anyone know what is going on here? it seems like the hideinterval: command applies to when my mouse leaves the dropdown menu, but not when it leaves the "services" button.

thanks for the help! let me know if you need anymore information.