PDA

View Full Version : Help needed with DD Tab Content Menu



quilford
05-07-2009, 07:21 AM
1) Script Title:
Tab Content Script (v 2.2)
2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex17/tabcontent.htm
3) Describe problem:
Quite simply, I have followed the instructions correctly, but when I load the page the content is not there (nor is it in the 'live view' option in Dreamweaver), and when I click on any of the tabs, still no content shows.

Any suggestions would be appreciated.
-Quilford

Snookerman
05-07-2009, 07:43 AM
Please post a link to the page on your site that contains the problematic script or attach your code so we can check it out and help you.

quilford
05-07-2009, 07:54 AM
I'll upload the test page.
http://www.spacetojump.com/games/testpage.html
there you go ;)

quilford
05-08-2009, 07:29 AM
Is there any fix?

ddadmin
05-09-2009, 07:23 AM
On this line inside your page:


var myflowers=new ddtabcontent("flowertabs") //enter ID of Tab Container

"flowertabs" needs to be changed to the ID of your tabs container.

quilford
05-10-2009, 02:44 AM
I applied your fix and updated the page, however it still does not work.

quilford
05-10-2009, 05:01 AM
Any other suggestions?

ddadmin
05-10-2009, 07:12 AM
Ah yes, your initialization code is currently defined in the HEAD section of the page. It should be defined following the tabs and tab contents on your page:


<script type="text/javascript">

var myflowers=new ddtabcontent("countrytabs") //enter ID of Tab Container
myflowers.setpersist(false) //toogle persistence of the tabs' state
myflowers.setselectedClassTarget("link") //"link" or "linkparent"
myflowers.init()

</script>

quilford
05-12-2009, 07:38 AM
not working, unfortunately :(

any other suggestions?

quilford
05-13-2009, 07:04 AM
or not?

ddadmin
05-13-2009, 08:31 PM
Found another error with your set up:


<div class="tabs">

<ul id="countrytabs" class="shadetabs">
<li><a href="#" rel="country1" class="selected"><span><span>Picks</span></span></a></li>
<li><a href="#" rel="country2"><span><span>Previews</span></span></a></li>
<li><a href="#" rel="country3"><span><span>Videos</span></span></a></li>
<li><a href="#" rel="country4"><span><span>Features</span></span></a></li>
</ul>
</div>


Inside your rel attributes for each tab, you're referencing "country1", "country2" etc, which do not correspond to the IDs of the DIVs which you wish to show/hide.

When in doubt about the proper format of your HTML, please refer back to the original code on the script page (http://www.dynamicdrive.com/dynamicindex17/tabcontent.htm). There seems to be a lot of little problems with your implementation of the script.

quilford
05-15-2009, 07:44 AM
no? bump

ddadmin
05-15-2009, 04:29 PM
no? bump

You didn't fix the issue I last mentioned about your rel attributes pointing to non existent elements (ie: "country1", "country2" etc).

quilford
05-19-2009, 06:00 AM
hello?

ddadmin
05-19-2009, 04:33 PM
Please read and implement what I had posted at #11 above.

quilford
05-24-2009, 08:38 AM
hello?

quilford
05-29-2009, 08:17 AM
hello?!

quilford
05-29-2009, 08:18 AM
oh, jeez, sorry!! for some reason my computer wasn't displaying your newer messages, until I did a hard refresh! whoops!

quilford
05-29-2009, 08:52 AM
http://www.spacetojump.com/games/testpage.html

The tabs seem to be working (in terms of hiding and displaying content), however only 1 piece of content shows (the 'Royal Flush' image). I have looked at the tags surrounding the image and compared them to others, but could find no mistake.

Help would be appreciated, and once more, sorry for my posting screwups.

quilford
06-04-2009, 10:51 AM
hi? are you there?