PDA

View Full Version : Resolved Animated Collapsible DIV issue with ie7 help



Evan Leavitt
05-04-2009, 07:49 AM
1) Script Title: Animated Collapsible DIV v2.2

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/animatedcollapse.htm

3) Describe problem: Im having trouble with ie7 the fade is not working correctly. click here (http://mediamason.net/aceleather/store/backpacks.php) to view page, the first product "trigger clip" click on "learn more". But the strange thing is if I preview the page from dreamweaver to ie7 it works from the temp file. any help would be appreciated. Thanks -Evan

ddadmin
05-05-2009, 05:17 AM
Hmm at a glance I'm not sure why the fade isn't working in IE. I do notice a scripting error on your page, however:


Error: frmElement is undefined
Source File: http://mediamason.net/aceleather/store/select.js
Line: 29

What happens if you disable the above script?

Evan Leavitt
05-05-2009, 06:59 AM
Thank you for your reply. I have taken out that script completely and I have reuploaded the page but it still has the same issue.

page without script (http://mediamason.net/aceleather/store/backpacks.php)

ddadmin
05-05-2009, 11:33 PM
Hmm this is a strange one. I've tried a few things, and at this point, my best guess is most likely you have unclosed DIV tags in the vicinity of the DIVs being expanded/contracted that's throwing IE off. If I define a new expandable content outside your page layout (ie: immediately following the BODY tag), the fade effect works in IE:


<a href="javascript:animatedcollapse.toggle('test')">Learn MoreĽ</a>

<div id="test">
sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />sdfs sdf sdf<br />
</div>

Evan Leavitt
05-06-2009, 03:14 AM
an unclosed div is something I should look into. I was also up last night laying in bed and thought it might be a css hack that makes this effect reacts this way. I will be busting it out in a couple hours and post if anything is or isn't found. thanks for the guidance.

-Evan

Evan Leavitt
05-06-2009, 06:22 AM
Well it turned out to be a css issue, it wasn't a hack like I thought it might. The divs were inside a class that set img position relative once I created a new class without img properties the issue was resolved.
Thank you for your help, this script saved me from creating a separate page for each product and we're talking over 200 products. It was nice to have someone to bounce ideas off of.
Thanks again!

FIXED PAGE (http://mediamason.net/aceleather/store/backpacks.php)

-Evan

ddadmin
05-06-2009, 08:51 PM
Glad you were able to find the culprit. That was certainly an elusive one.