PDA

View Full Version : JavaScript (maybe CSS) Issue with IE7



firefly_x
03-25-2009, 08:15 PM
Yeah I know, IE. I have a site I am working on and I am using a DynamicDrive JavaScript Library, so I figured I'd ask here. The library is at:

http://www.dynamicdrive.com/dynamicindex4/thumbnail.htm

The problem is that the CSS layer for the enlarged photo is not pulling up correctly in IE7. It should create (make visible) a new CSS layer with a high z-index so it is on top of the page, a la "LightBox style" - but in IE7 it just loads a typical browser page with the photo. At the top of the .js file in the notes, it mentions that there was an IE fix last summer, regarding images not showing; is this the same issue or a new one? Did the .js file I downloaded not get updated?

My website can be seen at: http://www.whobrokemyworld.com/natecarvey/project1.html

Everything seems to work beautifully in FF, Chrome, Safari, Opera and IE8. Thanks for any advice!

Master_script_maker
03-25-2009, 09:03 PM
seems to be working in my ie7

firefly_x
03-25-2009, 09:19 PM
So when you visit Screenshot1 and click an image, it renders like Screenshot2? For me, in IE7 it renders like Screenshot3, it loads a totally new page, no new layer unhide.

Screenshot #1

http://www.whobrokemyworld.com/natecarvey/screenshots/ncarvey1.jpg

Screenshot #2

http://www.whobrokemyworld.com/natecarvey/screenshots/ncarvey2.jpg

Screenshot #3

http://www.whobrokemyworld.com/natecarvey/screenshots/ncarvey3.jpg

firefly_x
03-26-2009, 08:34 AM
Anyone?

I'm sue this is a CSS problem ow, can we move it to that section Mods?

firefly_x
03-30-2009, 05:35 AM
bump.

codeexploiter
03-30-2009, 06:37 AM
hi firefly_x,

I have checked it in IE8, IE7 and IE6.

In IE8 and IE7 everything seems to be working but in IE6 the design seems to be broken when compared to the view of IE8 and IE7. But this issue is not the one that you've mentioned in your post. When I click the thumbnail images the full image loads as it should in all the above mentioned IE versions.

firefly_x
03-30-2009, 09:12 AM
That's what everyone tells me but I have now tried IE 6, 7 and 8 myself and it loads the photo to a new page even in IE 8!!! Does anyone know why that would happen on my computer? JavaScript is turned on, and I just downloaded IE8, so why won't it work?