PDA

View Full Version : Lightbox & Navbar Issue



Timothyvb
03-22-2009, 08:21 AM
Hi,

I am new to this forum.

I have got some problems regarding lightbox on my website. Lightbox is working perfectly fine, however it only works when i get rid of my navigation bar script in the <head> section. <head> section is as follows;


<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<meta name="Generator" content="iWeb 3.0" />
<meta name="iWeb-Build" content="local-build-20090322" />
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<meta name="viewport" content="width=700" />
<title>CS 2</title>
<link rel="stylesheet" type="text/css" media="screen,print" href="CS_2_files/CS_2.css" />
<link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen,print" />
<!--[if lt IE 8]><link rel='stylesheet' type='text/css' media='screen,print' href='CS_2_files/CS_2IE.css'/><![endif]-->
<!--[if gte IE 8]><link rel='stylesheet' type='text/css' media='screen,print' href='Media/IE8.css'/><![endif]-->
<script type="text/javascript" src="Scripts/Widgets/SharedResources/WidgetCommon.js"></script>
<script type="text/javascript" src="Scripts/Widgets/Navbar/navbar.js"></script>
<script type="text/javascript" src="Blank_2_files/Blank_2.js"></script>

<script type="text/javascript" src="js/prototype.js"></script>
<script type="text/javascript" src="js/scriptaculous.js?load=effects,builder"></script>
<script type="text/javascript" src="js/lightbox.js"></script>
</head>


When I apply it like this it works fine, however this script is missing and essential for my website.


<script type="text/javascript" src="Scripts/iWebSite.js"></script>

I have tried every possibility to incorporate both scripts in the head section but it keeps messing around with my template.

Does anybody know how to fix this?

Thanks a lot!!

PS. I am editing an iWeb webpage.