PDA

View Full Version : Ajax Tabs Content Script (v 2.2)



atomic
03-19-2009, 01:29 PM
1) Script Title: Ajax Tabs Content Script (v 2.2)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/index.htm

3) Describe problem:

Hi i am trying to use ajaxtabs and SexyLightBox2 (http://www.coders.me/ejemplos/sexy-lightbox-2/) on the same page.

SexyLightBox initalises in the head like this:


<script type="text/javascript">
window.addEvent('domready', function(){
new SexyLightBox();
new SexyLightBox({find:'sexywhite',color:'white', OverlayStyles:{'background-color':'#000'}});
});
</script>

when i load a new content using AjaxTabs the SexyLightBox links in the new content wont work, while SLB links on the rest of the page works fine (i would expect that).

So how can i re-initalise the above code when using AjaxTabs to load new content into a DIV?(i guess this would be a problem for any script that get initalised in the head)

thank you very much for any assistance.


NB. i realise that this is a multiple script question, but i think it is a basic javascript question as well, and i am new to this and just looking for some assistance.

atomic
03-19-2009, 08:51 PM
I've been trying for quite a while now and i still dont have the answer, any good samaritans?

I would have thought this would be a no-brainer for Javascript-gurus

Andy_
03-27-2009, 01:58 PM
i found a solution that might help you, however im not sure why it doesnt do it as it should.

i basically used the explicit javascript command on the href.

e.g.

<a href="javascript: blah.loadajaxpage('some_file.php')">TEXT LINK</a>


blah being the thing you specified in the below script

<script type="text/javascript">

var blah=new ddajaxtabs("nav", "holder")
blah.setpersist(true)
blah.setselectedClassTarget("link") //"link" or "linkparent"
blah.init()

</script>

hope this helps,

Andy.

goldspace
08-06-2009, 06:41 PM
Can this work in a form? I'm not having any luck with it.



<FORM name="form1" action="javascript: countries.loadajaxpage('/addlink.asp')" enctype="multipart/form-data" method="post">

I'm trying to open this page in the same tab container it starts from, but it doesn't seem to be working at the moment.

Anyone have any ideas?

Thanks!