PDA

View Full Version : Positioning question with Chrome menu



thesoundsmith
03-09-2009, 09:12 PM
1) Script Title: Chrome CSS Drop Down Menu v2.5

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/chrome/

3) Describe problem: I used this post to resolve the horizontal positioning

http://www.dynamicdrive.com/forums/showthread.php?t=39596

The menus now appear directly below the upper menu item, but they are too far below the line. I played with adding a negative offset in the .js file, but I can't find a tweak that works in both ie6 and ff.

ddadmin
03-09-2009, 09:21 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.

thesoundsmith
03-09-2009, 11:23 PM
Sorry - the regular page, no drop down items, which works correctly, is here:
http://www.thesoundsmith.com/private/cofallico.htm

The first pass is at http://www.thesoundsmith.com/private/a_test.htm
The menu functions, but the submenus are severely offset. I followed advice from another post and put the submenus at the end of the divs, and...

The next version with the Chrome menu now displays the main top "nav" menu and subs in both IE and FF, but the "sidemenu" in "sidebar" is now broken. It is here:
http://www.thesoundsmith.com/private/a_test1.htm

But there are 80-odd pages to update, and I don't want to have to redo the side menus (most pages have them.) Where to correctly place the new menus? This is not my template and I'm not a CSS expert by any means - I thought I understood the layout, but apparently I don't, I don't see why the sidebar is broken...

ddadmin
03-10-2009, 09:13 AM
Inside chromestyle.js, try adding the line in red below:


.dropmenudiv{
position: absolute;
top: 0;
left: 0;
border: none; /*THEME CHANGE HERE*/
border-bottom-width: 0;
font:normal 12px Verdana;
line-height:18px;
z-index:100;
background-color:#B9FFB9;
width: 200px;
visibility: hidden;
}


BTW, the link to your first pass is broken btw (local reference): file:///J:/thesoundsmith/web/private/a_test.htm

thesoundsmith
03-10-2009, 06:44 PM
Oops - grabbed the wrong page and posted the link from WeBuilder, but I corrected it (and some coding errors, both pages now pass W3C) but W3C does not like your script notice, I had to remove it to pass the check, then re-install.)

But I believe you meant chromestyle.css, not the .js doc. And it didn't change anything

I have tried moving things around in a number of ways, without luck. Either the side menu is broken (the NAV is still operational) or the menus just don't open. Adding the "left=0" helped the original a_test.htm align horizontally, but the menus are still too far down the screen. If there is an equally easy fix for that, I'd be a happy camper...