PDA

View Full Version : Simple Controls Gallery bottom description



CoolD78
03-03-2009, 06:34 PM
1) Script Title: Simple Controls Gallery

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm

3) Describe problem: Is there a way to make the description panel slide up from the bottom of the image? The description panel is on top by default. I want to turn off the Nav Panel and replace it with the Description Panel.

Please advise. Thanks,
Dan

CoolD78
03-04-2009, 03:04 PM
I figured out how to have the description panel to slide up from the bottom, but I can't get it to work in Joomla 1.5. Can anyone give me a reason why I can't get this to work in Joomla?

Thanks

ddadmin
03-05-2009, 08:30 AM
Are you saying you're having trouble getting even the default version of SCG to work on Joomla, or just the modified version you've made? A link to the problem page would help.

CoolD78
03-05-2009, 12:33 PM
I'm currently testing the modified version on Joomla, not the default version. I think I will try testing the default version next.

The browser is reading the simplegallery.js file since I can edit the background color and width and height, but the image will not appear on the page. I was wondering if it is problem with the imagearray string.

Here is a link to the page I am testing: http://www.katart.com/jm/

I've tried removing the Superfish menu and that didn't make a difference and I also tried putting the script in the head as well as the body and that didn't make a difference.

Modified simplegallery.js is attached

CoolD78
03-05-2009, 01:20 PM
Thanks for looking into this for me. After more testing, I got it working on my Joomla site.

http://www.katart.com/jm/

CoolD78
03-05-2009, 04:33 PM
After further testing, I realized that my menu drop downs are appearing behind the Simple Control Gallery panels. I edited my CSS to fix this problem and it works fine in Safari and FF.

Here is the CSS:

.sf-menu li:hover ul, .sf-menu li.sfHover ul {
top: 9.0em;
left: 0.8em;
z-index: 10000;
}

Here is the site I am testing: http://www.katart.com/jm/

Can someone let me know what I am missing? Thank you

ddadmin
03-06-2009, 06:12 AM
Hmm where's your CSS that styles #simplegallery1, simplegallery2 etc? By default it looks something like:


<style type="text/css">

/*Make sure your page contains a valid doctype at the top*/
#simplegallery1{ //CSS for Simple Gallery Example 1
position: relative; /*keep this intact*/
visibility: hidden; /*keep this intact*/
border: 10px solid darkred;
}

#simplegallery1 .gallerydesctext{ //CSS for description DIV of Example 1 (if defined)
text-align: left;
padding: 2px 5px;
}

</style>

Going by the above, you can try giving #simplegallery1 a z-index that's smaller than that given to your CSS menu.

CoolD78
03-06-2009, 01:45 PM
Thanks for the reply. I put the #simplegallery CSS in my template.css file. I added the z-index to the #simplegallery1 style, but to get it to work, I had to create a position: relative for some of the top level DIVs.

Thanks again for your input. I enjoy getting these sites to work, but getting there can be frustrating.