PDA

View Full Version : Image Thumbnail Viewer problem with Flash animations



doockey81
02-19-2009, 09:25 PM
1) Script Title: Image Thumbnail Viewer

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/thumbnail.htm

3) Describe problem: The script for the Image thumbnail viewer is great, but it has problems if the site contains flash animations, the big picture appears under the flash animation, I tried to increase the z-index of the picture, but it don't works.
Please help, You're doing great job, I love Your scripts.

Greetings.

You can see it on this link:
www.ssooiobih.ba

jscheuer1
02-20-2009, 06:08 AM
I see that you are using AC_FL_RunContent for the flash. You need to add the wmode transparent, ex:


<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','769',
'height','147','src','main','wmode','transparent',
'quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','main' ); //end AC code

</script>
<noscript>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="769" height="147">
<param name="movie" value="main.swf" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />
<embed src="main.swf" width="769" height="147" quality="high" wmode="transparent"
pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash"></embed>
</object>
</noscript>

doockey81
02-20-2009, 09:29 AM
Thanks a lot, now it works fine. You are great, thanks again.