PDA

View Full Version : Any link css menu v2.0



BMarcos
02-19-2009, 11:31 AM
1) Script Title: Any link css menu v2.0

2) Script URL (on DD): ANY LINK CSS MENU V2.0 (http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm)

3) Describe problem:
In Firefox and Opera the script working fine ...
I have a problem with scripts in IE. The page no open ...



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
<head>
<title><?php
if (is_home()) {
echo bloginfo('name'); echo " - "; echo bloginfo('description');
} elseif (is_404()) {
echo 'Aceasta categorie nu cuprinde momentan nici un articol.';
} elseif (is_category()) {
echo 'RADIOUNISON.RO -'; wp_title('');
} elseif (is_search()) {
echo 'Rezultatul cautarii - ';
} elseif (is_day() || is_month() || is_year() ) {
echo 'RADIOUNISON.RO -'; wp_title('');
} else {
echo 'RADIOUNISON.RO - '; wp_title('');
$subtitle = get_post_meta($post->ID, 'Subtitle', $single = true);
if($subtitle !== '') { echo ' - ' . $subtitle; }
} ?></title>
<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>">
<meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->
<meta name="">
<meta name="keywords" content="">
<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
<link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?> Atom Feed" href="<?php bloginfo('atom_url'); ?>" />
<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

<link rel="stylesheet" type="text/css" href="<?php bloginfo('stylesheet_directory'); ?>/css/anylinkcssmenu.css" />

<script type="text/javascript" src="<?php bloginfo('stylesheet_directory'); ?>/js/anylinkcssmenu.js">

/***********************************************
* AnyLink CSS Menu script v2.0- Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Project Page at http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm for full source code
***********************************************/

</script>

<?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>

<?php wp_head(); ?>
</head>
<body onLoad="show_clock()">
<!-- *** INCEPUT BODY *** -->
<table width="970" align="center" cellpadding="0" cellspacing="0" border="0">
<tr>
<td class="top_bg">

</td>
</tr>
<!-- *** INCEPUT HEADER *** -->
<tr>
<td valign="top" class="middle_bg">
<table width="970" cellpadding="0" cellspacing="0" border="0">
<tr>
<td valign="top">
<table width="690" cellpadding="0" cellspacing="0" border="0">
<tr>
<td style="padding-left: 30px;">
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="910" height="200">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="<?php bloginfo('stylesheet_directory'); ?>/flash/flashradiounison.swf" />
<param name="quality" value="high" />
<embed src="<?php bloginfo('stylesheet_directory'); ?>/flash/flashradiounison.swf" quality="high" width="910" height="200" name="fade" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</td>
</tr>
</table>
</td>
</tr>
</table>
</td>
</tr>
<!-- *** SFARSIT HEADER *** -->
<!-- *** INCEPUT MAIN BODY *** -->
<tr>
<td class="middle_bg">
<table width="970" cellpadding="0" cellspacing="0" border="0">
<tr>
<td height="5">
</td>
</tr>
<!-- *** INCEPUT MENIU *** -->
<tr>
<td>
<table id="orizontalLimitMeniu" width="970" cellpadding="0" cellspacing="0" border="0">
<tr>
<td width="30"></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/left_corner.gif" width="11" height="35" border="0"></td>
<td width="650" class="middle_corner">
<!-- *** INCEPUT COD SUPLIMENTAR MENIU *** -->
<table width="650" cellpadding="0" cellspacing="0" border="0">
<tr>
<td valign="top">
<!-- *** SFARSIT COD SUPLIMENTAR MENIU *** -->
<table width="650" cellpadding="0" cellspacing="0" border="0">
<tr>
<td class="navtextMainMeniu"><a href="">Home</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="http://www.dynamicdrive.com" class="anchorclass myownclass" rel="submenu3">Resurse</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="">Linkuri</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="">Contact</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="">Despre noi</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="">Cartea de oaspeti</a></td>
<td><img src="<?php bloginfo('stylesheet_directory'); ?>/images/navlimitbut.gif" width="4" height="35" border="0"></td>
<td class="navtextMainMeniu"><a href="">Grila de program</a></td>
</tr>
</table>
<!-- *** INCEPUT SUBMENIUL *** -->

<div id="submenu3" class="anylinkcsscols">

<div class="column">
<b>Web Development</b>
<ul>
<li><a href="http://www.dynamicdrive.com/">Dynamic Drive</a></li>
<li><a href="http://www.cssdrive.com">CSS Drive</a></li>
<li><a href="http://www.javascriptkit.com">JavaScript Kit</a></li>
<li><a href="http://www.codingforums.com">Coding Forums</a></li>
<li><a href="http://www.javascriptkit.com/domref/">DOM Reference</a></li>
</ul>
</div>

<div class="column">
<b>News Related</b>
<ul>
<li><a href="http://www.cnn.com/">CNN</a></li>
<li><a href="http://www.msnbc.com">MSNBC</a></li>
<li><a href="http://www.google.com">Google</a></li>
<li><a href="http://news.bbc.co.uk">BBC News</a></li>
</ul>
</div>

<div class="column">
<b>Technology</b>
<ul>
<li><a href="http://www.news.com/">News.com</a></li>
<li><a href="http://www.slashdot.com">SlashDot</a></li>
<li><a href="http://www.digg.com">Digg</a></li>
<li><a href="http://www.techcrunch.com">Tech Crunch</a></li>
</ul>
</div>

</div>
<script type="text/javascript">
<!--
anylinkcssmenu.init("anchorclass")
-->
</script>

<!-- *** SFARSIT SUBMENIUL *** -->


My link a page is http://www.utx.ro/unison/new/

ddadmin
02-20-2009, 04:12 AM
Using IE7, I get the prompt "IE cannot open the following page..." This error doesn't sound like a script related error at all actually, but a domain one. Are you sure it's due to the script? If you remove it from your page, are you able to view the page again in IE?

BMarcos
02-20-2009, 10:06 AM
Yes, I remove the script from page and the page work fine. In Opera and Firefox ... the script is funtional.

ddadmin
02-20-2009, 08:14 PM
Hmm I really don't see how the script could cause the page to be inaccessible in IE. Of course, saving your page offline and trying to view it in IE works, so it's hard to debug that way. Can you remove the Anylink CSS Menu script from your page- just that script- so I can confirm without it the page is accessible again in IE?

BMarcos
02-20-2009, 10:30 PM
I remove the script and my page work fine.

Check www.utx.ro/unison/new (http://www.utx.ro/unison/new/)

ddadmin
02-22-2009, 06:26 PM
That's strange indeed. My best guess at this point is that there are broken references to external files of the script when you added it to your page. Is there a way you can get me to duplicate the problem on my own server? For example, if you zip up the entire contents of your page and sent it to me, and I were to upload that page onto my server, would I get the same result in IE? Right now as mentioned saving your page as a local copy then running it doesn't cause the same "page not able to load" error in IE, so it's hard for me to diagnose the problem.