PDA

View Full Version : Simple Controls Gallery Image Size



wormann
02-18-2009, 09:50 PM
1) Script Title: Simple Controls Gallery v1.3

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/simplegallery.htm

3) Describe problem: I would like to use this script but I have images of varying sizes - horizontal(landscape) and vertical(portrait). I noticed in the code that the dimensions should reflect the exact size of the images as shown here.


var mygallery=new simpleGallery({
wrapperid: "simplegallery1", //ID of main gallery container,
dimensions: [250, 180], //width/height of gallery in pixels. Should reflect dimensions of the images exactly
Is there a way to use this script with different image dimensions? I would like to have a max size div container, and then have the images center to the middle of the container.

Thanks in advance if anyone can help with this.

ddadmin
02-19-2009, 01:30 AM
Hmm there's no quick way to center the images inside the viewer at the moment unfortunately, as they are positioned absolutely. I'll consider adding in such an ability the next time the script is updated.

wormann
02-19-2009, 06:06 AM
Thank you for your response about centering images of different dimensions. I have just created pngs instead of jpegs to get around this and it is working as a quick fix.

I have uploaded the gallery and have it working fine - almost. I have chosen not to include descriptions but in IE7 it shows null where the description field should be on every image it loads. The slider that rolls down with your description is not there, just the word null in the upper left hand corner. Of course in FF null doesn't show up - the viewer works fine.

I have tried everything I can think of to modify the script and get this to go away but I haven't been sucessful.

Also, is it possible to have the images appear in random order?

Again, any help would be appreciated.

ddadmin
02-20-2009, 04:17 AM
Please post a link to the page on your site that contains the problematic script so we can check it out.

wormann
02-25-2009, 01:52 AM
thank you so much for your help. I have actually decided to go with a different script because it takes the page a long time to load (I'm assuming this is because the images are preloading in the background). The script I am using has an option to turn pre-loading off, when it is on I have the same problem of long load times.

When still trying to use the Simple Controls Gallery to get around the null option, I created a style for the text to appear as 0 px and had it a close color to the background image. You could still see a dot on page load but it was another quick fix.

clj83
05-11-2009, 09:09 AM
Which gallery are you using as an alternative? I am also having a problem of long load time.