PDA

View Full Version : Problem with filters



nic-del
07-31-2005, 03:13 PM
having a problem with the following, not entirely sure what I've done wrong! it's supposed to add a filter to a picture so that the area around the mouse turns transparent...
head

<style>
<!--

#myimage{
filter:alpha(opacity=20);
}

-->
</style>

Body

<script language="JavaScript1.2">


s = 50; // the size of the spotlight
vp = 10; // the visibility percent of the picture
startx = 0; // the top position of your sportlight into the image (on start)
starty = 0; // the left position of your spotlight into the image (on start)



var IE = document.all?true:false

function moveL()
{
xv = tempX;
yv = tempY;
myimage.filters.alpha.opacity<100;
}

if (IE&&myimage.filters)
document.all.myimage.onmousemove = getMouseXY;
var tempX = 0
var tempY = 0


function getMouseXY(e) {
tempX = event.offsetX
tempY = event.offsetY

if (tempX < 0){tempX = 0}
if (tempY < 0){tempY = 0}
if (t)
{
moveL();
}

return true
}

var xv = startx;
var yv = starty;
var t= true;
if (IE&&myimage.filters){
myimage.filters.alpha.opacity<100
myimage.filters.alpha.addPoint(startx,starty,s,255,255,255,255)
}

</script>

if anyone can offer any assistance it would be much appreciated

Twey
07-31-2005, 03:24 PM
To start with:
filter: is IE-only. This is bad. More detail on CSS opacity can be found here (http://www.mandarindesign.com/opacity.html). You should adjust the script.

The language= attribute is deprecated. Use type="text/javascript".

I'm afraid I can't help you further, because I don't have IE.