PDA

View Full Version : Resolved Lightbox V2.03.3



ollyno1uk
01-14-2009, 03:03 PM
1) Script Title:

Lightbox

2)url

http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:

I have a couple of minor issue with this script. One is in IE7, on some images I am getting scroll bars on the caption section below the image - I cannot work out why.

Secondly in Firefox when i click an image, the image starts somewhere in the middle of the image gallery rather than image 1 of xx - IE here is fine.

If anyone could help that would be great.

The url I am working on is

http://www.nationwideltd.co.uk/electric-garage-doors.php

Though I am still working on this right now trying to solve it so may change a bit.

Thanks a lot

jscheuer1
01-15-2009, 06:32 AM
In IE 7, though it looks like you've fixed this, it appears that you are using the css for a later version of lightbox. If you are still having that problem, use this css:

http://www.dynamicdrive.com/dynamicindex4/lightbox2/css/lightbox.css

In FF, you have your links here:


</tr>
<!-- Gallery images-->


<a href="images/woodgrain_door_large.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/two_white_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/4_green_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/garage_with_visi.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/large_white_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/external_fit.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/linked_external.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/resident.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/doubledoor.jpg" rel="lightbox[garagedoors]"></a>

<a href="images/insidecasing.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/usingremote.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/g-garage-large.jpg" rel="lightbox[garagedoors]"></a>
<!--Footer below here-->
</table>
</div>

In an invalid location. FF shifts them to the beginning of the page in the DOM. You may move them here (after the closing </table> tag):


</tr>
</table>
<!-- Gallery images-->


<a href="images/woodgrain_door_large.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/two_white_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/4_green_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/garage_with_visi.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/large_white_doors.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/external_fit.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/linked_external.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/resident.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/doubledoor.jpg" rel="lightbox[garagedoors]"></a>

<a href="images/insidecasing.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/usingremote.jpg" rel="lightbox[garagedoors]"></a>
<a href="images/g-garage-large.jpg" rel="lightbox[garagedoors]"></a>
<!--Footer below here-->
</div>

ollyno1uk
01-15-2009, 08:46 AM
Hi John and thanks a lot for taking the time to help.

I will move the gallery - I see why this has happened.

With regards to IE7 - I added the margin:0 and padding:0 to the body tag within CSS which cured most issues though on images 14 and 15 I still am getting a scroll bar appear right where the caption is.

Thanks again

ollyno1uk
01-15-2009, 09:54 AM
Ah I hadn't correctly changed to the CSS file you mentioned - this cleared up the problem.

Thanks a lot