PDA

View Full Version : Mouse Over image pop-up for ff2x+



VsUK
12-29-2008, 05:48 PM
Hi, i have set this script up i got here http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm
It works perfect for internet explorer but it just fails with firefox. Nothing pops up & sometimes i see a flicker n then nothing.

I cant find anything that fits the job as good as the script dynamicdrive have & i really need it to work. Can anyone help or have any advice? I really depend on frontpage but understand where most code goes & what not, just not very good at writing it from hand :D

thanks

Snookerman
12-29-2008, 05:51 PM
Well the demo on DD works in Fx so I assume you mean your own code and there is no way we can help you unless you give us a link to your site or attach the code you are using. Also, next time post questions about DD script in the DD scripts help forum (http://www.dynamicdrive.com/forums/forumdisplay.php?f=2).

Nile
12-29-2008, 05:52 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.
Please include your code so that we can take a look at it, we can't do much without it.

A link to your page would be better than the code. :-/

Snookerman posted first. :(

Nile
12-29-2008, 06:14 PM
It appears you don't have a doctype.

VsUK
12-29-2008, 06:17 PM
how would i fix this? it works perfect on IE but most users use FF & thats when i discovered the problem. Im not a fantastic coder, i mainly go from help sites n tutorials :D

Snookerman
12-29-2008, 06:18 PM
I see you page doesn't have a doctype, add this at the top of your page, before the <html> tag:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

VsUK
12-29-2008, 06:21 PM
ok, added that & uploaded, however now IE popups are distorted & still no effect with firefox :/

Snookerman
12-29-2008, 06:26 PM
Try validating your page (http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fowlife.co.uk%2FSovereign%2Fkixwoods.html) as well.

VsUK
12-29-2008, 06:33 PM
wow, that is a very nice site to use & to avoid future problems.. nice, ill go threw my pages & see on the results n let you all know if it works. :D

thanks

VsUK
12-29-2008, 06:56 PM
ye, i undid that & now im only getting 63 error's which are things like
put tooltip div just before </BODY>. */ which is not open & same for everything else not open. I dont get that as everything works perfect except trying to get mouse over popup images.

jscheuer1
12-30-2008, 04:03 AM
[B]Don't any of you folks ever test the page before throwing out advice that you have no idea will solve the problem or not?
[end short rant]

Anyways, add this to the head of your page:


<style type="text/css">
#tipDiv, #tipDiv * {
width: auto!important;
}
</style>

Some refinement may be required, but for your example page, this looked good.

Some of the other advice given previously in this thread is good general advice even though it didn't solve your problem. Some of it was completely wrong, I've tried to remove those and still leave generally good advice and responses. But the real solution is as I've stated in the code block in this post.