PDA

View Full Version : Falling Snow Script Problem in Firefox v3.0.4



Kidcessory Haven
12-03-2008, 09:22 AM
1) Script Title: Snow Effect

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex3/snow.htm

3) Describe problem: The 'snow' is having a 'blizzard' on my home page here;
http://www.kidcessoryhaveninc.com when viewed in Firefox v3.0.4.
It is working perfectly in IE, and I had no issues with this same script in either browser last year.

I can see the script fine in your demo so I am wondering if it is possibly an issue with the Yahoo Sitebuilder that I use. Unfortunately, they will not give me any support with outside scripts, so I am turning to you for help.

I have tried placing the script in different places, however that just makes the 'blizzard' move to the line I've placed it. I use this 'cut-and-paste' sitebuilder as I am 'html challenged', should we say...so please talk to me like I am a baby.... :rolleyes:

I have searched the forums/archives and have seen this issue come up before, but have not seen a solution to it so I thought I'd re-post the tread.

Thanks for looking into this for me - Lisa

jscheuer1
12-03-2008, 09:48 AM
The problem is that due to an overuse (abuse really) of absolute positioning, your page has no layout height in FF, so the script sees nowhere for the snow to fall. As a result, it just keeps dancing around at the top of the page. Add (highlighted):


. . . haveninc.com/kidcessory-haven-flower-favicon.ico" type="image/vnd.microsoft.icon" /> <!--$end pageHtmlBefore$-->
</head>
<body bgcolor="#FFFFFF" background="clipart/backgrounds/fullpage/sunFlowerBg.gif" text="#000000" link="#006600" vlink="#CC3300" topmargin="0" leftmargin="0">

<!--$begin exclude$-->
<div id="centerwrapper" style="height:100%;">
<div id="root" style="position:absolute;width:960px;height:2106px;">
<!--$end exclude$-->
<div id="e0" style="position:absolute;lef . . .

Kidcessory Haven
12-03-2008, 01:47 PM
John.....

You absolutely ROCK!!

Thank you!!!!!!!