PDA

View Full Version : Need help with "image tooltip"



forumslog
07-19-2005, 12:54 PM
I put "image tooltip" into my site, it's in http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm, everything looks fine, does it? but it doesn't in my site, please refer to: http://www.top10-florists.com/horoscope.htm, notice that when you drag the scrollbar down, then you put your mouse over the links, the image doesn't show up as it should be, instead it shows up above the mouse cursor, the more the page you drag down, the more space it has, you can't even see the image when the links appear at the bottom of the page. But the script works well in other browers, like Firefox. Please help me figure it out, really appreciate that. Thanks in advance.

IanMarlowe
07-19-2005, 01:17 PM
try renaming calla lily to 5. you have it set as 4.
change the rest as needed.

what are these:

http://ad.linksynergy.com/fs-bin/show?id=yQ0pmTf*e3Y&bids=82744&type=2&subid=0

http://ad.linksynergy.com/fs-bin/show?id=/Xyz2Ai0GzE&bids=84219.451519861&type=10&subid=

?

aren't they supposed to be pictures?

nice look though, I like the scorpio (I am scorpio)

:)

jscheuer1
07-19-2005, 02:27 PM
Here's the real fix, this has come up a few times with this and other event positioned scripts here that haven't gotten the doctype/document.body update yet. Do a global search and replace on the script:

search for:

document.body

replace with:

iecompattest()

Then add this function to the script:

function iecompattest(){
return (document.compatMode && document.compatMode.indexOf("CSS")!=-1)? document.documentElement : document.body
}It can go just about anywhere but, for simplicity's sake, put it just above the credit:

<script language="javascript" type="text/javascript">
<!--

function iecompattest(){
return (document.compatMode && document.compatMode.indexOf("CSS")!=-1)? document.documentElement : document.body
}

/*
Image w/ description tooltip- By Dynamic Web Coding (www.dyn-web.com)
Copyright 2002 by Sharon Paine
Visit http://www.dynamicdrive.com for this script
*/

forumslog
07-20-2005, 05:28 AM
Hi, jscheuer1, thank you very much, the problem has been solved, everything looks fine, you're really a genius, hope to get your helps again next time.