View Full Version : Help with RSS Display Boxes

11-09-2008, 03:56 PM
1) Script Title: RSS Display Boxes

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex18/rssdisplaybox/index.htm

3) Describe problem: No RSS content is displaying.

I have set everything up and there are no RSS feeds showing up at all on demo.htm. I checked for SimplePie compatibility and it said I'm OK.

Here's the link:

What am I doing wrong? I know I have to edit the line in the rssdisplaybox.js from this:
var rssoutputscript="rssbox/main.php"

to this
(Is this connection right?)

So what do I need to do to make this work? I'm gonna need a step by step explanation.

I'm using Yahoo as a host. Does that make a difference? I can't really change chmod permission...unless you guys know how.

Thanks in advance.

11-10-2008, 03:38 AM
Right now the path you're specifying to main.php inside your .js file is based on this line:

var rssoutputscript="rssbox/main.php"

The other line is commented out ("//" preceeding it), so it's not used. That's fine, as based on the above, it assumes main.php is located here, which from what I can tell it is indeed:


Now what is a problem is that when I try to go to that URL above, all I get is a blank page. This tells me Simpiepie isn't running properly on your server for some reason. When you call main.php with no parameters, you should get the output:

Error: Can't find requested RSS in list.

Did you remember to chmod 777 the cache directory used by the script? If that doesn't help, inside main.php, right after the opening <? tag, try adding the line in red to enable error debugging:


Now run main.php again in your browser, and see what error message gets output.

11-10-2008, 04:40 AM
Just a blank field. I did plug the script in right and I'm still getting a blank field.


So now what?

Then again, how do I chmod a folder on Yahoo?

11-11-2008, 06:30 AM
Inside your RSS cache directory, do you see any files deposited in there? If not, it means the permissions aren't correct. It's possible Yahoo doesn't allow a directory to be chmod 777, in which you may want to try chmod 775 instead and see if that suffices.

11-18-2008, 01:03 PM
How do I do that?

11-18-2008, 10:41 PM
Do you mean how to chomd directories? First, did you check to see if any files are currently in your cache folder? They should be automatically generated files, which if there are would indicate your cache directory already has the correct permissions. As far as how to chmod directories, if you use a FTP program to connect to your server, you'd simply right click on the directory in question, then select the chmod/modify permissions option. I'm not sure if Yahoo lets you upload files using a FTP program, however.