PDA

View Full Version : Lightbox next and back buttons not showing??



bob-dobelina
11-03-2008, 08:06 PM
I'm really hoping someone can help me with this as I'm going crazy, it's my first post as well.

I've read all the other posts regarding the lightbox next and previous buttons not showing up and I've done everything suggested, still not working.

Here is my site: http://www.iantilton.net/theatre/gallery.html

The buttons don't even show up?? All of my thumbnails and larger images are in the same folder.

Here's the part of my code from the Lightbox.css file, also uploaded the whole thing.

#prevLink, #nextLink{ width: 49%; height: 100%; background-image: url(data:image/gif;base64,AAAA); /* Trick IE into showing hover */ display: block; }
#prevLink { left: 0; float: left;}
#nextLink { right: 0; float: right;}
#prevLink:hover, #prevLink:visited:hover { background: url(prevlabel.gif) left 15% no-repeat; }
#nextLink:hover, #nextLink:visited:hover { background: url(nextlabel.gif) right 15% no-repeat; }

I even tried an absolute url to the images and that doesn't work. Can anyone help, I'll bet it's something really obvious.

Cheers
Bob

jscheuer1
11-03-2008, 08:24 PM
There could be other problems, but there will be no next/previous unless you are using the lightbox group syntax:


rel="lightbox[groupname]"

not:


rel="lightbox"

Example using roadtrip as a group name:


<a href="images/image-1.jpg" rel="lightbox[roadtrip]">image #1</a>
<a href="images/image-2.jpg" rel="lightbox[roadtrip]">image #2</a>
<a href="images/image-3.jpg" rel="lightbox[roadtrip]">image #3</a>

The groupname may be whatever you like, use the same one for all the images in a particular group.

bob-dobelina
11-04-2008, 09:09 AM
Brilliant, thank you for your help. that works perfect.

kevgroat
11-24-2009, 08:47 AM
new guy to html as well...
i've tried the [groupname] method.

one thing i have had to work around is that i've placed each of my lightbox galleries containing multiple images all off of one single image on my page, which i solved by a previous post (thanks by the way).
but i have also had to work around my single displaying images being rollovers.

Files are all organized and referenced.

Everything works fine I can click through my images except the next/prevlabels just aren't showing.

here's a copy of my code:

<a href="../images/photos/01chicago_skyline.jpg" rel="lightbox[a]"title="Chicago skyline" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image24','','../images/images/workrollover_24.gif',1)"><img src="../images/images/work_24.gif" alt="Photography" name="Image24" width="179" height="61" border="0" id="Image24" /></a><a href="../images/photos/02_soxwin.jpg" rel="lightbox[a]"title="Sox win"></a>


thanks ahead of time,,,,

kevgroat
11-24-2009, 09:07 AM
works now. something didn't direct to those images correctly....


thanks anyway, GREAT site. you'll hear more from me i'm sure. :)