PDA

View Full Version : Featured Content Slider v2.4 doesn't work on IE6



Kanana
10-10-2008, 01:15 PM
1) Script Title: Featured Content Slider v2.4 FF1+ IE5+ Opr7+

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/featuredcontentslider.htm

3) Describe problem: Hi,
This script is installed on my main page and some users doesn't see the slider.
I know that it affects only user under IE6.
I tested on IE7, Firefox (mac/PC) and there is no PB.

On the script description, it's written it's supposed to work on IE5+...

Any idea?

Kanana

ddadmin
10-10-2008, 10:27 PM
The DD demos work fine for me in IE6. Is this something specific to your page? Please post a link to the page on your site that contains the problematic script so we can check it out.

Kanana
10-11-2008, 11:17 AM
Hi,

Thanks for your answer.

My page is http://www.dundalkbulls.com on the top story part


Kanana

ddadmin
10-11-2008, 08:53 PM
Did you switch to Ajax Tabs Content script instead? FYI your page works in IE6 for me.

Kanana
10-11-2008, 10:21 PM
Well, I didn't change anything since then, and the issue appears on different PC having IE6...What should I change to your opinion?

ddadmin
10-12-2008, 07:20 AM
Ok, I was confused, since looking at your page's source, the prominent code at the top points to "Ajax Tabs Content Script". Anyhow, I see Featured Content Slider now further down the source. Again though, in IE6, the Top Stories box works for me. It's possible you have a dated version of IE6 with a multimedia bug. To confirm this, try disabling the fade feature within FCS:


featuredcontentslider.init({
id: "slider1", //id of main slider DIV
contentsource: ["inline", ""], //Valid values: ["inline", ""] or ["ajax", "path_to_file"]
toc: "#increment", //Valid values: "#increment", "markup", ["label1", "label2", etc]
nextprev: ["-", "-"], //labels for "prev" and "next" links. Set to "" to hide.
revealtype: "click", //Behavior of pagination links to reveal the slides: "click" or "mouseover"
enablefade: [false, 0.2], //[true/false, fadedegree]
autorotate: [true, 8000], //[true/false, pausetime]
onChange: function(previndex, curindex){ //event handler fired whenever script changes slide
//previndex holds index of last slide viewed b4 current (1=1st slide, 2nd=2nd etc)
//curindex holds index of currently shown slide (1=1st slide, 2nd=2nd etc)
}
})

Kanana
10-13-2008, 10:40 AM
Thanks for your answer.

I tried to change what you advised me, but there is no difference unfortunately.

I attached you a screenshot if that can help you.

Thanks again

Kanana

ddadmin
10-14-2008, 05:49 PM
Hmm do you have more details on the copies of the IE6 browsers that you say don't work? Since your page works for me in IE6, it's hard to debug. Disabling the fade feature should account for the problematic IE6 browsers that I was aware of. Since it doesn't, another possibily is that another script on your page (ie: The Ajax Tabs Content script) is the one throwing an error, hence stopping the rest of the scripts from working in IE6 for you somehow. To verify this, start with a clean blank page with just the Featured Content Slider in it and fade disabled, and see if that works.

Kanana
10-15-2008, 03:19 PM
Thanks again for your answer

IE 6 version is 6.0.2900.2180xpsp_sp2_gdr070227-2254
On my PC and on another one that has the issue.

I made a clean page with the slider (false) at : www.dundalkbulls.com/slider_test.php but , on my side it appear blank.
I attached a screen shot of what I see.

Thx