PDA

View Full Version : Switchcontent Expanding issue



Gumarx
09-29-2008, 03:48 PM
1) Script Title: switchcontent

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/switchcontent.htm

3) Describe problem:
See: http://www.franklin.uga.edu/students/advising/events/cultrules.htm

The expandable content on the page was running fine, then another person in the office posted updates to an area higher up on the page and now the last expandable content does not expand. Everything in the code seems okay to me. All the other expandable sections are still working, and I'm not sure exactly what changes were made but I think the only thing they added was the obnoxious large red box at the top. Any insight?

Here's the code for good measure:
<ul>
<li>
<strong id="caepcontent12-title" class="handcursor">HOW CAN I MAKE SURE I HAVE GOTTEN CREDIT FOR ALL THE EVENTS I HAVE ATTENDED?</strong>
</li>
</ul>
<div id="caepcontent12" class="switchgroup1">
<blockquote>
a bunch of text that I didn't want to take up space copying
</blockquote>
</div>
<script type="text/javascript">
var bobexample=new switchcontent("switchgroup1", "div") //Limit scanning of switch contents to just "div" elements
bobexample.setColor('black', 'darkred')
bobexample.setPersist(true)
bobexample.collapsePrevious(true) //Only one content open at any given time
bobexample.init()
</script>

Jon101
09-29-2008, 06:39 PM
I checked it on FF and Safari - seems to be working fine. Unfortunately I don't have IE on this machine though...

Are you still experiencing the problem?

Gumarx
09-29-2008, 07:17 PM
Yes, I checked in FF and Seamonkey and still see the issue. I don't have IE on this machine. It could be that I don't have the latest edition of Firefox (2.0.0.15) or Seamonkey - since I don't have admin rights on the machine I can't do the updates. I've refreshed but is there something else I should try that might be causing the hang-up?

The section that is not expanding is "HOW CAN I MAKE SURE I HAVE RECEIVED CREDIT FOR ALL THE EVENTS I HAVE ATTENDED?" In both browsers I test in it shows up as regular black text and clicking on it does nothing (vs the maroon text that will expand). All sections except that one will expand properly.

UPDATE: I had someone try in IE7, and Chrome and it wasn't working in their browsers either.

Jon101
09-29-2008, 07:24 PM
I see there is something else calling the same class on the top of the page:

<p><strong class="handcursor" id="caepcontent12-title">Special Note for Performing Arts majors (Music, Theatre, Dance)<br>

<br>


That could be the issue... try changing the number.

Sorry i didnt see it before - i was looking at the wrong section.

Gumarx
09-29-2008, 07:42 PM
That did it. That isn't supposed to be tagged with a class so that must have been one of the changes made (which makes sense - she sent out an e-mail to all of us with the same information) and somehow that information was copied from somewhere where it brought the class along. Thanks a bunch - I guess an extra set of eyes was all I needed.

Jon101
09-29-2008, 07:44 PM
You're welcome!

:D

Jon

ddadmin
09-29-2008, 07:45 PM
Please be specific in terms of actually which header no longer "works", and under what circumstances. A simple step by step procedure to duplicating the problem would be best.

Gumarx
09-29-2008, 08:31 PM
Please be specific in terms of actually which header no longer "works", and under what circumstances. A simple step by step procedure to duplicating the problem would be best.


The area I was working with was the area specified in the code titled "HOW CAN I MAKE SURE I HAVE RECEIVED CREDIT FOR ALL THE EVENTS I HAVE ATTENDED?" - but the page is working now. Thanks for the response.