PDA

View Full Version : Lightbox only works once



simcomedia
09-16-2008, 06:33 PM
Lightbox Image Viewer 2.03

http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

On this page i'm using the DD Ajax dynamic content loader AND the lightbox image viewer. Clicking on the thumbnails summons the various pages into the content area via the Ajax. Contained in the summoned pages is the image that when clicked on will open in the lightbox window. When you first go to the page and click on the image to view it works fine...the first time. Then select another thumb on the left and try viewing the new pic. The lightbox effect doesn't happen and the larger image simply appears in a new page. Refresh the page and the same thing happens, first time it works and remainder don't.

Each 'page' summoned into the Ajax content area is reliant upon the <head> section of the main page for the CSS formatting and the lightbox effects (as well as other javascript processes). Therefore those pages do not themselves contain any reference to the lightbox .js files except for the required rel= in the image tag.

http://www.nicholsbros.com/flwgallerytest3.htm

I'm stumped on this one. Need another set of eyes to help me figure out why the lightbox isn't working on each new page called into the main page.

simcomedia
09-16-2008, 10:20 PM
Just an FYI on this, I also just set up 'FaceBox' as well and it does the same thing.

jscheuer1
09-17-2008, 04:31 AM
Upgrade to lightbox v2.04:

http://www.lokeshdhakar.com/projects/lightbox2/