PDA

View Full Version : Tab Content Script (v 2.2) not working in IE



ultras.nick
09-10-2008, 06:55 PM
1) Script Title: Tab Content Script (v 2.2)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/tabcontent.htm

3) Describe problem:

The script above does not work for me in IE. The problem is that after the page loads, the 1st tab is loaded, but when I click on the other tabs, t nothing is displayed. Simply the 1st tab is unloaded and then - nothing. In Firefox works just fine.

I personalized it and the code is below for the tabs.

<td width="470" height="229" valign="top" class="style3">

<div style="padding-left:50px" align="left">
<ul id="countrytabs" class="shadetabs">
<li><a href="#" rel="country1" ><img src="poze/culori/culori_04.png" border="0" /></a></li>
<li><a href="#" rel="country2" ><img src="poze/culori/culori_01.png" border="0" /></a></li>
<li><a href="#" rel="country3"><img src="poze/culori/culori_03.png" border="0" /></a></li>
<li><a href="#" rel="country4"><img src="poze/culori/culori_02.png" border="0" /></a></li>
</ul>
</div>


<div style="border:0px solid gray; width:350px;">

<div align="center" id="country1" class="tabcontent">
<img src="poze/aparat4.png" /></div>

<div align="center" id="country2" class="tabcontent">
<img src="poze/aparat2.png" /></div>

<div align="center" id="country3" class="tabcontent">
<img src="poze/aparat3.png" /></div>

<div align="center" id="country4" class="tabcontent">
<img src="poze/aparat1.png" /></div>
</div>

<script type="text/javascript">

var countries=new ddtabcontent("countrytabs")
countries.setpersist(true)
countries.setselectedClassTarget("link") //"link" or "linkparent"
countries.init()

</script></td>

Thanks in advance.
Any help will be highly apreciated :)

Regards.

ddadmin
09-11-2008, 06:03 PM
Please post a link to the page on your site that contains the problematic script so we can check it out.