View Full Version : Conveyor Belt Script Problem

10-12-2004, 11:59 AM
Thanks for the suggestion, is this better?

Conveyor Belt DD Script:
Greetings to all;

The problem that I've had with this (conveyor belt) script is finding a way to close the 'GAP" that appears between the pictures. I'm trying to create a continuous and seamless effect, Im using images that are exactly the same size which should follow one after another seamlessly. I edited the images in Photoshop to where the end of one image attaches exactly to the beginning of the next, and so forth... There is a really large, wide GAP that appears at the end of the last image before the cycle starts again; Any suggestions?

Any help with this issue would be greatly appreciated.
- Thanks.

10-12-2004, 03:00 PM
Could you demonstrate with an online example?


edited 13/10/04

10-13-2004, 08:53 AM
As cr3ative mentioned, in the future, please post in the proper format, by including a link to the script on DD, in this case: http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm Also, please don't use coloring for the text- the default black instead of blue will do nicely.

Regarding your question, I try and get to updating this script so the spacing is customizable, most likely late this week or the next.

10-14-2004, 05:24 AM
Ok, script updated so you can specify both the spacing between each image and slideshow rotations.

10-15-2004, 02:26 PM
Dear all

Sorry, I've another favour to ask someone regarding this conveyor belt script. As a final part, is it possible to have a piece of text set in a table to display information regarding whichever website thumbnail is hovered over?
I know it can be done in normal coding using swap-image/image restore, but being a JS code area, can this be done?

Again, many thanks..


10-19-2004, 02:52 AM
Thanks DDadmin and Cr3ative;
Is this good?
Re: Conveyor Belt Slideshow script

You're a Genius!
I think these revisions will work, I'll try it out on my slideshow and post an online example as soon as possible. Thanks, this seems to be the solution I was looking for; I actually resolved the gap between images by modifying the script,but Im not experienced enough to re-write the code for the ending gap so I just added a background image to the table cell that shows thru the gap; Thanks! -Graffxman

10-24-2004, 06:01 AM
in the fillup function, line:


play with the X value.

in my case a X=9 made the gaps equal with the closing gap, together with "freezing" the font-size at the end of the script:

write('<div id="test2" style="position:absolute;left:0px;top:0px;font-size:28px"></div>')
write('<div id="test3" style="position:absolute;left:-1000px;top:0px;font-size:28px"></div>')

10-25-2004, 08:05 PM
This is my first time posting so I hope I get all the information correct.

Conveyor Belt DD Script located at:
working example of the changes can be found at:

I, too, was having problems with the major gap where the show starts again. The tail end of the "belt" would completely disappear as soon as 1/3 of the first picture appeared on the right hand side. I was able to fix mine by changing the following near the end of the script:

write('<div style="position:absolute;width:'+sliderwidth+';height:'+sliderheight+';background-color:'+slidebgcolor+'" onMouseover="copyspeed=0" onMouseout="copyspeed=slidespeed">')


write('<div style="position:relative;width:'+sliderwidth+';height:'+sliderheight+';background-color:'+slidebgcolor+'" onMouseover="copyspeed=0" onMouseout="copyspeed=slidespeed">')

Then I played with the slideshowgap variable at the beginning of the script until it seamed in nicely.

Just something to try. :)

03-12-2005, 04:22 AM
Ok, script updated so you can specify both the spacing between each image and slideshow rotations.

Can you tell me the error of my way? I've uploaded to http://hellobrooklyn.com/llkfb/

I'd like to get rid of the gaps between the images.

Thanks for your help

03-21-2005, 03:02 AM
This is how I got rid of the gaps...

//Specify gap between each image (use HTML):
var imagegap=""

//Specify pixels gap between each slideshow rotation (use integer):
var slideshowgap=-3

for some reason '-3' fixed it, maybe just experiment with that number
a bit.

12-20-2005, 08:35 PM

Thank you, I was having that same problem (the last image disappearing instead of being streamline as one continous loop).

I'm surprised at the age of your post that DD hasn't made mention of that on the page of the script or just changing the script altogether.

By any means, awesome script.