PDA

View Full Version : DHTML Modal Window - Strange IE6 Issue



greddin
08-29-2008, 09:57 PM
1) Script Title:
DHTML Modal Window v1.1

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex8/dhtmlwindow/dhtmlmodal.htm

3) Describe problem:
I'm noticing a weird behavior. First, I tested my solution in a local server using IE6. The modal window works fine when launching IE6 locally. But when I hit the same page from across the Internet using IE6 I get a Javascript error.

The error is not very telling. Just says Line 288 Char: 2 Error: Unspecified error.

I tested in IE7 and FireFox 2 and 3. No problems.

I meticulously inserted debug alert()'s until I found the line of code that seems to be causing the trouble. It's in the dhtmlwindow.js file in the setopacity function.

This line:
if (targetobject.filters && targetobject.filters[0]){ //IE syntax

Again, it doesn't have a problem if I use IE6 from the local machine's desktop itself.

The page basically covers itself with the "veil" then stops with the error just before opening the modal window.

Has anyone come across this issue?

-Thanks

magicyte
08-29-2008, 10:00 PM
I haven't come across this issue. I use IE 7, finally, cuz I got a download. Here's a hint to the world: buy FF!!

-magicyte

greddin
08-30-2008, 03:52 PM
I just wanted to follow up from my previous post. This has been solved. My problem was that I had behaviors disabled in the IE6 browser settings.

Under Tools / Internet Options / Security tab / Internet Custom Level button / ActiveX controls and plug-ins / Binary and script behaviors.

I had a basic installation of IE6 and never manually set this to disabled. So it must install as disabled by default.