PDA

View Full Version : Thumbnail Viewer II: image placeholders appear on top of images



Timneh
08-24-2008, 02:56 AM
Thanks to an emailed suggestion that I add a transparent gif and point the image tag at it, my problem is solved!

============================================


1) Script Title:

Image Thumbnail Viewer II

2) Script URL (on DD):

http://www.dynamicdrive.com/dynamicindex4/thumbnail2.htm

3) Describe problem:

This script works perfectly in all the browsers I tested my page in except, of course, in Internet Explorer 5.5 through 8.0. There, although each thumbnail image appears (and each hover image appears), an image placeholder icon *also* appears on top of each thumbnail image.

When I started to add ALT text, the ALT text also appeared on top of each image, along with the dratted image icon. My page perfectly validates as CSS level 2.1 . The full sized images in the load area are not affected in this way. These icons did not appear on top of the images before I used the script. Why are the placeholder icons appearing when the images are there? Please tell me there is an easy IE fix, the script works beautifully everywhere else.

Page: http://www.billkeyart.com/bkad_canvas.html
CSS: http://www.billkeyart.com/bkad.css

Thanks for any suggestions.

Timneh
08-25-2008, 03:43 AM
One more thing: Along with the icons appearing on top of the thumbnail images, their border color (which is part of the image, not coded) has changed to a light blue tint:

http://www.billkeyart.com/example.html

Also, I just noticed that, although the image icons don't show up in Safari, the images have got that weird blue tinted border.

I am completely baffled by this weirdness and would appreciate ANY thoughts.


Thanks.