PDA

View Full Version : a question about "UNDEFINED"



marknicol
07-01-2005, 04:57 AM
why is it that when i upload the files i made in frontpage to geocities, when its already done and im ready to open my page, some of the cripts doesnt work or one example is that the scrolling script, after 1 scroll, the next message will be UNDEFINED.. what would be a great solution for dat? and for the pictures, they doesnt appear correctly... what seemed to be the prob? pls answer me guyz.. thank you very much! :)

jscheuer1
07-01-2005, 06:24 AM
Geocities (as are many free hosts) is a poor hosting choice when you are planning on using much javascript. Free hosts generally, Geocities in particular, put many of their own scripts on your page automatically when you upload them. These scripts often conflict with some or all of your own scripts on your page rendering them nonfunctional or dysfunctional. The real test is, if it works locally but, not on Geocities, it could well be script conflicts, there are other possibilities. Two of the biggest conflicts arise when your script uses i or j as variables (Geocities hi-jacks those for its own scripts) or if your scripts attempt to put offsite material inside a frame or iframe on Geocities (they've got scripts designed to prevent that). In the first case you can change all i's used as variables to other more complex variable names, same with j's but, of course, use a different name for all the j's used as variables. The second problem has no work around that I know of.

Specifically, the undefined is a common problem with the scrolling script, are you having the problem locally though? If not, it is probably Geocities adding a doctype that you didn't have or a script conflict. Your question about pictures is too general, what exactly is the problem? They don't display at all? Are they in the wrong place? Do they look funny?

To be of any more help, we need to know what works locally, just not on Geocities, as well as what isn't working locally. And we need to see the code.

.