View Full Version : splash page

07-16-2008, 12:39 PM
1) Script Title: splash page script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex3/dynamicsplash.htm

3) Describe problem:

I'm using Nuke evolution system on my site, and I installed the splash script on it. I also have it installed on the nuke evolution system I run locally on my xampp server on my laptop.

the problem is that on my xampp server it will load normally (so if sessiononly, only shows every session etc...) but when I upload it to my online site it doesn't matter if I put it on sessiononly or 1 days, 2 days... it will show the splash page every time I load a page.

any help is appreciated

07-16-2008, 02:37 PM
Please post a link to the page on your site that contains the problematic code so we can check it out.

07-17-2008, 12:27 PM
oh yeah ok, srry about that.

I had to remove it cause it would be annoying for my visitors, but I'll upload a copy of my site on a test site as soon as I get back from work.

the link should be http://idealvisions.org/test

07-17-2008, 02:58 PM
Nothing there at the moment but a 404 not found.

07-17-2008, 03:52 PM

the link "would" be...

still at work but leaving now, but I'll post when it will be up. thanks for your help

07-18-2008, 06:21 AM

ok it's up, the script is set to sessiononly (and it doesn't call google but just a normal page)

07-18-2008, 12:21 PM
well know it seem to work properly on my test page, changed the cookie path to /test

but still doesn't work properly on my site -> http://cmstut.idealvisions.org/index.php

it's a subdomain what should I put as cookie path?

07-19-2008, 10:01 AM

07-19-2008, 10:05 AM
How is it a subdomain? I mean the paths look comparable:




07-19-2008, 12:32 PM

this is just a fold I created in the root of the site


this is a subdomain

I just wanted to ask if there was a difference and if you had to change cookie path...

07-19-2008, 01:03 PM
Oh, I missed that. I see what you are talking about now. I really don't know the answer to that question. Using:


is supposed to set the cookie for all pages on the domain. I don't see where it would matter that the domain were a subdomain, but it might.

You could try:

//5) cookie setting: ["cookie_name", "cookie_path"]
cookiename: ["splashpagecookie", "path=" + location.href],

That would limit it to the page itself, but be more precise.

07-19-2008, 01:19 PM
Another thing to try would be:

//5) cookie setting: ["cookie_name", "cookie_path"]
cookiename: ["splashpagecookie", "path=/; domain=idealvisions.org"],

07-21-2008, 07:59 AM
nope :( didn't work :(

if you have other suggestions they are welcome :D but it doesn't matter cause I didn't really need it I just wanted to test it out.

07-21-2008, 08:59 AM
One other idea I have would be to try a different set of routines for the cookie. However, I'm not certain if that would be any better. Here:


is a set of cookie routines I often rely upon. If these were to be successfully integrated into the script in place of its current routines, it might make a difference.

The only other idea I can think of at the moment is that there may be some sort of conflict with another script on or associated with the page.