PDA

View Full Version : Formatting problem in tabs



newbees
07-08-2008, 01:07 PM
Script: DD Tab Menu
http://www.dynamicdrive.com/dynamicindex17/tabcontent.htm

I am using this script and if I import any data that contains line breaks (<br />) or tables, it just ignore it and put all text, letters one after annother. It has no paragrafs, tables, line breaks, anything. Just plain wall of text.

I am not putting text in tabcontent divs, I am using joomla modul to get text from an article. I cant provide link to the page yet. Everything I do inside article, the result is the same. Im just asking if this have something to do with this script or colision between joomla and dd tab.

Thanks

jscheuer1
07-08-2008, 02:03 PM
From what you say, I would guess it's the latter. More likely the particular method for fetching the text you are using. But if the content you are fetching has no formatting to begin with, that would explain it as well. It certainly isn't the script itself removing elements, as there is clearly text formatting on the demo page for the script.

You might want to consider switching to:

http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/index.htm

which can fetch external content itself, as long as that content is on the same domain. But this will not help if the imported content has no formatting to begin with. For that, almost any workable method of importation would do, then it would be up to your css style and/or some sort of code routine to add format to it.