PDA

View Full Version : Resolved Problem with DHTML Window Widget



bengaon
07-05-2008, 04:01 PM
1) DHTML Window Widget

2) Script URL (on DD): https://www.epays.co.il/Web/Payment.asp?ConfirmID=xCSf7IHu75W60VL5XJtf85ic0Wws0Emp83b4EQp11XXa2EMq2LCn1RQkKXF03Lt82Sj54Yql3GgiJMuy5Tjv4AY442N36NVypTKw42yt6Ook6Ud250r87Ih77OorS7Eh8CSf7IHu75 W60VL5XJtf85# (Just click on the "ePays" text, on the top right side).

3) Describe problem: I'm using SSL, and when I use IE and click on the Dhtml window, it says that the are some things, which are not secure (and there are not).

From this, I learn that somethings is wrong with the script (I even tried to use a black page, and it still said that there are some unsecured things).

I'm using the Iframe function in the script.

I really need your help,
Thanks!
Bengaon.

jscheuer1
07-05-2008, 04:46 PM
You need to use an https page.

bengaon
07-05-2008, 05:02 PM
I'm using an https page.

One is on the page that contains the script, and one is the page which has the information that shows on the Iframe.

jscheuer1
07-05-2008, 07:30 PM
In the script, the iframe uses a (at least to start out), I think it's a:


src="about:blank"

You need to change that to your blank https page. You didn't link to the script on DD here, or I could be more helpful:

Warning: Please include a link to the DD script in question in your post. See this thread (http://www.dynamicdrive.com/forums/showthread.php?t=6) for the proper posting format when asking a question.

I did try your page but got no warning about non-secure content when activating the widget, perhaps you've fixed it but have an earlier version cached in your browser. Close all instances of the browser. Open it and delete all files (clear the cache), then try loading your page and activating the widget.

bengaon
07-05-2008, 07:46 PM
Hello John,

It worked! I changed it from src="" to an https address.

I thank you for your fast answer.

P.S.

What do you mean I did not linked to the DD script address? I linked to the script page, did you mean linking to the scripts files? (j.s. files?)

Thank's!
bengaon.

jscheuer1
07-05-2008, 07:54 PM
What do you mean I did not linked to the DD script address? I linked to the script page, did you mean linking to the scripts files? (j.s. files?)

As long as you have your answer to your problem, I'm not going to worry about this too much. To answer your question (quoted above) though, as far as I could see, and I may have missed something, you never posted a link to the script's demo page on Dynamic Drive, the page you got the script from, its official demo page in the Dynamic Drive Library. This is only important when there is (and there often is) some question as to exactly what script you (or whoever's asking) are having trouble with. It also helps in researching the code for modifications that my be useful to the particular issue at hand.

bengaon
07-05-2008, 07:56 PM
Ha...........

Ok.
Thank's for you help.