PDA

View Full Version : Featured Content Slider and selectors



mvfaccin
06-23-2008, 05:54 AM
1) Script Title: SLIDER SELECTOR PROBLEMS

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex17/featuredcontentslider.htm


3) Describe problem:
I'm creating my website and would like to insert the slide show as example 2 showed. I'd like to modify it a bit, putting the selectors on the left side, but I don't understand how.
Also, I cannot change the image position inside the frame. As you see in my file "products 2", the image appeares on the top left, while I'd like it in the middle. What Am I doing wrong?

I'm attaching two files:
1)Products 2: to show you what I did.
2) Product: this is where I'd like to insert the slide show: On the middle-right.
I'd like to call the slide show from the menu' on the left.
Can I use the menu as selectors, don't I?


Please help!
Thanks

ddadmin
06-23-2008, 07:39 AM
Well, generally speaking, you can construct the pagination links any way you when you specify the "toc" parameter in you initialization code to "markup":


featuredcontentslider.init({
id: "slider1", //id of main slider DIV
contentsource: ["inline", ""], //Valid values: ["inline", ""] or ["ajax", "path_to_file"]
toc: "markup", //Valid values: "#increment", "markup", ["label1", "label2", etc]
"
"

When you do this, you manually specify the pagination links' HTML, as long as they are links and contained inside a DIV with ID "sliderid-paginate". So to create a "menu" look, your pagination links may look something like:


<div id="paginate-slider1" class="pagination">

<ul class="markermenu">
<li><a href="#" class="toc">Page 1</a></li>
<li><a href="#" class="toc">Page 2</a></li>
<li><a href="#" class="toc">Page 3</a></li>
<li><a href="#" class="next">Next</a></li>
</ul>

</div>

And the CSS for the menu may look like:


<style type="text/css">

.markermenu{
list-style-type: none;
margin: 5px 0;
padding: 0;
width: 170px;
border: 1px solid #9A9A9A;
}

.markermenu li a{
font: bold 13px "Lucida Grande", "Trebuchet MS", Verdana, Helvetica, sans-serif;
color: #00014e;
display: block;
width: auto;
padding: 3px 0;
padding-left: 20px;
text-decoration: none;
border-bottom: 1px solid #B5B5B5;
}


* html .markermenu li a{ /*IE only. Actual menu width minus left padding of LINK (20px) */
width: 150px;
}

.markermenu li a:visited, .markermenu li a:active{
color: #00014e;
}

.markermenu li a:hover{
color: black;
background-color: #ffffcb;
}

</style>

mvfaccin
06-23-2008, 09:53 PM
Hi,

thanks for your quick reply, I really appreciate it!

I did what you told me to do, but it's a mess. The layout is wrong and still I cannot get to see the pictures on at the right of the menu-selector.

Can you please double check my page and tell me what's wrong?

many thanks!
Mavi

ddadmin
06-24-2008, 01:22 AM
It's a lot easier to debug if you put the problem page online, and provide a link to it. This also takes care of the issue of the missing external files referenced in your attached HTML page.

mvfaccin
07-07-2008, 12:56 PM
Hi ,

I uploaded my website, but it's quite a mess.
I cannot show you what I did on the 'products page' as th enest doesn't work toward any page.
What's wrong? I worked on it to find it out, but I didn't understand what it is.

Also, on the index page, two out of three slide shows work, why I can't make the second one work,?

can you please help me?


my website is: www.ca-usa.us


Thanks
MV

ddadmin
07-07-2008, 07:59 PM
The page you cited above (http://www.ca-usa.us/) contains the Swiss Army Slideshow script, not the Featured Content Slider. Or am I missing something? If the problem is still with the later script, please post the link to the actual demo page featuring that script and what you have so far and what doesn't work.

mvfaccin
07-07-2008, 09:18 PM
Hi,

I recap the situation:
the problem originally was with the featured content slider. I was creating my website offline and everything was working beside that.
So I wrote you and you suggested me to put the site online for an easier check.

I did so and doing it new problems came out. These problems are:

- swiss army not working on the slide show2;

- nesting not working: this one prevent you from going to the "Products" page, where I used the Featured Content Slider I was talking to you about.
I still have problems with the Featured Content Slider, but I can't show you what I did if I cannot nest to that page.

Can you please suggest me what's wrong with the home page so I can show you the Featured Content Slider problem?


MV