PDA

View Full Version : Fade-In Slideshow (v1.51) with pics online does not work?



roos
04-29-2008, 03:42 PM
1) Script Title: Ultimate Fade-In Slideshow (v1.51)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

3) Describe problem: I was trying hard to show up the pictures with the nice Fade-in slideshow but does not work. Can anyone tell me what the problem is? I copied part of the code below... I can only think on two possibilities, my webpage lacks structure (i'm just starting to build it) or the script does not accept online linked pictures?

Thanks for your help.

Roos

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>

<title>Roosevelt Garcia-Villacorta
* Ultimate Fade-In Slideshow (v1.51)</title>

/***********************************************
* Ultimate Fade-In Slideshow (v1.51): Dynamic Drive (http://www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit http://www.dynamicdrive.com/ for this script and 100s more.
***********************************************/

var fadeimages=new Array()
//SET IMAGE PATHS. Extend or contract array as needed
fadeimages[0] = ["http://roosevelt.garcia.googlepages.com/yavaripics_112.jpg", "", ""] //image with link syntax
fadeimages[1] = ["http://roosevelt.garcia.googlepages.com/yavaripics_085.jpg", "", ""] //
fadeimages[2] = ["http://roosevelt.garcia.googlepages.com/yavaripics_045.jpg", "", ""] //
fadeimages[3] = ["http://roosevelt.garcia.googlepages.com/yavaripics_037.jpg". "", ""] //
fadeimages[4] = ["http://roosevelt.garcia.googlepages.com/yavaripics_016.jpg", "", ""] //
var fadebgcolor="white"

////NO need to edit beyond here/////////////

DELETED HERE+++++++++++++++++++++++++++++++++DELETED HERE

}
this.rotateimage()
}

</script>

</head>

<body>

<script type="text/javascript">
//new fadeshow(IMAGES_ARRAY_NAME, slideshow_width, slideshow_height, borderwidth, delay, pause (0=no, 1=yes), optionalRandomOrder)
new fadeshow(fadeimages, 640, 480, 0, 3000, 1, "R")
</script>

<style type="text/css">
.glossymenu{
list-style-type: none;
margin: 5px 0;
padding: 0;
width: 170px;
border: 1px solid #9A9A9A;
border-bottom-width: 0;
}

.glossymenu li a{
background: white url(http://roosevelt.garcia.googlepages.com/glossyback.gif) repeat-x bottom left;
font: bold 13px "Lucida Grande", "Trebuchet MS", Verdana, Helvetica, sans-serif;
color: white;
display: block;
width: auto;
padding: 3px 0;
padding-left: 10px;
text-decoration: none;

}


* html .glossymenu li a{ /*IE only. Actual menu width minus left padding of A element (10px) */
width: 160px;
}

.glossymenu li a:visited, .glossymenu li a:active{
color: white;
}

.glossymenu li a:hover{
background-image: url(http://roosevelt.garcia.googlepages.com/glossyback2.gif);
}
</style>

<p><br></p>
<p><br></p>
<p><br></p>

<ul class="glossymenu">
<li><a href="research.html">Research</a></li>
<li><a href="publications.html/">Publications</a></li>
<li><a href="people.html">People</a></li>
<li><a href="teaching.html">Teaching</a></li>
<li><a href="links.html">Links</a></li>
<li><a href="sofware.html">Software</a></li>
</ul>

<address>Made 27 April 2008<br>
by myself.</address>

</body>
</html>

thetestingsite
04-29-2008, 04:05 PM
Just looking at the code you posted, you are missing the opening script tag. Replace your above code with this:



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>

<style type="text/css">
.glossymenu{
list-style-type: none;
margin: 5px 0;
padding: 0;
width: 170px;
border: 1px solid #9A9A9A;
border-bottom-width: 0;
}

.glossymenu li a{
background: white url(http://roosevelt.garcia.googlepages.com/glossyback.gif) repeat-x bottom left;
font: bold 13px "Lucida Grande", "Trebuchet MS", Verdana, Helvetica, sans-serif;
color: white;
display: block;
width: auto;
padding: 3px 0;
padding-left: 10px;
text-decoration: none;

}


* html .glossymenu li a{ /*IE only. Actual menu width minus left padding of A element (10px) */
width: 160px;
}

.glossymenu li a:visited, .glossymenu li a:active{
color: white;
}

.glossymenu li a:hover{
background-image: url(http://roosevelt.garcia.googlepages.com/glossyback2.gif);
}
</style>
<title>Roosevelt Garcia-Villacorta</title>

<script type="text/javascript">
/***********************************************
* Ultimate Fade-In Slideshow (v1.51): Dynamic Drive (http://www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit http://www.dynamicdrive.com/ for this script and 100s more.
***********************************************/

var fadeimages=new Array()
//SET IMAGE PATHS. Extend or contract array as needed
fadeimages[0] = ["http://roosevelt.garcia.googlepages.com/yavaripics_112.jpg", "", ""] //image with link syntax
fadeimages[1] = ["http://roosevelt.garcia.googlepages.com/yavaripics_085.jpg", "", ""] //
fadeimages[2] = ["http://roosevelt.garcia.googlepages.com/yavaripics_045.jpg", "", ""] //
fadeimages[3] = ["http://roosevelt.garcia.googlepages.com/yavaripics_037.jpg". "", ""] //
fadeimages[4] = ["http://roosevelt.garcia.googlepages.com/yavaripics_016.jpg", "", ""] //
var fadebgcolor="white"

////NO need to edit beyond here/////////////

DELETED HERE+++++++++++++++++++++++++++++++++DELETED HERE

}
this.rotateimage()
}

</script>

</head>

<body>

<script type="text/javascript">
//new fadeshow(IMAGES_ARRAY_NAME, slideshow_width, slideshow_height, borderwidth, delay, pause (0=no, 1=yes), optionalRandomOrder)
new fadeshow(fadeimages, 640, 480, 0, 3000, 1, "R")
</script>

<p><br></p>
<p><br></p>
<p><br></p>

<ul class="glossymenu">
<li><a href="research.html">Research</a></li>
<li><a href="publications.html/">Publications</a></li>
<li><a href="people.html">People</a></li>
<li><a href="teaching.html">Teaching</a></li>
<li><a href="links.html">Links</a></li>
<li><a href="sofware.html">Software</a></li>
</ul>

<address>Made 27 April 2008<br>
by myself.</address>

</body>
</html>


If this still does not work, please post a link to your problem page.

Hope this helps.

roos
04-29-2008, 04:46 PM
Hi there, I tested the suggestion but did not work. Here is a link to my HTML code online:

http://docs.google.com/Doc?id=dc4hkhdk_12pnf6d5xb

Thanks!

Roos

jscheuer1
04-30-2008, 05:38 AM
Typo:


fadeimages[3] = ["http://roosevelt.garcia.googlepages.com/yavaripics_037.jpg". "", ""] //

It should be a comma, not a period:


fadeimages[3] = ["http://roosevelt.garcia.googlepages.com/yavaripics_037.jpg", "", ""] //

P.S. thetestingsite is right about needing the opening script tag as well, but I see you now have it in the code you linked to.

roos
05-01-2008, 01:39 AM
Thanks John, and Thetesting site! my slideshow is working great! Roos