PDA

View Full Version : HVMenu & Conveyor Belt Slideshow



dmwhipp
03-21-2008, 03:46 PM
1) Script Title: HVMenu and Conveyor Belt Slideshow

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex1/hvmenu/index.htm
http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

3) Describe problem: I cannot get these two to work together.
The menu works fine here: http://www.dwwebdesigns.com/cc/index.html

But when I add the Conveyor Belt Slideshow, the slideshow works and the menu no longer appears: http://www.dwwebdesigns.com/cc/index2.html

I'm also using the Fading Message Scroller on this page.

This is exactly what they're looking for, so any help in getting these scripts to work together would be very much appreciated.
Thanks,
Deborah

P.S.
I tried the following:

Replace this (in the conveyor script):

Code:
window.onload=fillupwith:

with
Code:
if ( typeof window.addEventListener != "undefined" )
window.addEventListener( "load", fillup, false );
else if ( typeof window.attachEvent != "undefined" )
window.attachEvent( "onload", fillup );
else {
if ( window.onload != null ) {
var oldOnload = window.onload;
window.onload = function ( e ) {
oldOnload( e );
fillup();
};
}
else
window.onload = fillup;
}

This made both scripts work in IE, but then the slideshow no longer appeared in Firefox

dmwhipp
03-21-2008, 05:07 PM
I continued to play with the suggestions in different threads, and it appears I have the sample page working with HVMenu, Conveyor Belt Slideshow, and Fading Message Scroller. I'm away from my desktop and don't have Netscape on my laptop.

If you are able to, could you test this in your different browsers and let me know if all three scripts are working?
http://www.dwwebdesigns.com/cc/index.html
Thanks,
Deborah