PDA

View Full Version : Linking to offsite graphics [HV Menu]



Spiffshine
05-26-2005, 02:24 PM
Script: HV Menu 5.5
http://www.dynamicdrive.com/dynamic...vmenu/index.htm
--------------------------------------------------------------------------

I have used HV Menu at http://www.jamestownjammers.com/ and it works great!

However, a few of the pages (team statistics, etc.) are hosted and served by a third-party. For these pages I need to supply a Template with absolute URLs for all links and graphics... including the menu.

I have tried to accomplish this 3 ways:


1) Include absolute URLS for all images in _com file, retain original _var file
EXAMPLE: Menu1=new Array("rollover:http://www.jamestownjammers.com/images/nav_home.gif:http://www.jamestownjammers.com/images/nav_home2.gif","http://www.jamestownjammers.com/index.php","",0,20,50);
RESULT: Works when tested if template files reside at www.jamestownjammers.com - when template resides on another domain, the images load, but break after rollover (see below for links)


2) Include absolute URLS for all images in _var file, retain original _com file
EXAMPLE: this.value="<img src='http://www.jamestownjammers.com/"+this.ri1+
RESULT: Rollover-state images display, but not regular images


3) Include absolute URLS for all images in _var file and _com file
RESULT: Rollover-state images display, but not regular images - very curious, I thought the whole thing would break when I changed both files! :confused:

The three Templates described above reside on the Jammers domain at:

http://www.jamestownjammers.com/JammersTemplate1.html
http://www.jamestownjammers.com/JammersTemplate2.html
http://www.jamestownjammers.com/JammersTemplate3.html
And a seperate domain/server at:

http://www.ewinys.net/Jammers/JammersTemplate1.html
http://www.ewinys.net/Jammers/JammersTemplate2.html
http://www.ewinys.net/Jammers/JammersTemplate3.html

Calling the JavaScript from another domain/server does not seem to be the issue, since the menu half-works. Perhaps it is the colon after http in the URL that is affecting the rollover: format in the script? Any ideas??

~I know only enough to be dangerous~

Spiffshine
05-26-2005, 03:20 PM
Now I am pretty sure that the issue has to do with the rollover code or format. I tried simply using a graphic rather than a rollover and the images show up just fine:

http://www.ewinys.net/Jammers/JammersTemplate4.html

It's not great, but it will work until I can figure out how to fix the rollover. Any help from someone more familiar with JavaScript would be greatly appreciated!

jscheuer1
05-26-2005, 04:30 PM
Try using the network path for the rollovers, ex:
Menu1=new Array("rollover://www.jamestownjammers.com/images/nav_home.gif://www.jamestownjammers.com/images/nav_home2.gif","http://www.jamestownjammers.com/index.php","",0,20,50);I'm not sure how this will work in your situation but, it has worked in others.

Spiffshine
05-26-2005, 06:39 PM
:) :) :)
That worked! Thank you so much!
Solution:
http://www.ewinys.net/Jammers/JammersTemplate4.html

PS: Etiquette advice needed - Now that the issue is resolved, how long is it customary to leave the test pages I had created on my server (linked above) for others to view if having the same problem?