PDA

View Full Version : Error and Slide Show not Working. Please help!



johnwboyd
02-22-2008, 04:47 PM
1) Script Title:

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm
&
http://javascriptkit.com/script/script2/verticalmenu.shtml

3) Describe problem: link menu going behind images: http://johnwboyd.info/drop_down

thetestingsite
02-22-2008, 04:53 PM
First off:

Your page is in violation of Dynamic Drive's usage terms (http://www.dynamicdrive.com/notice.htm), which, among other things, states that the credit notice inside script must stay intact. Please reinstate the notice first.

Second, you may want to re-copy the code as it is on the demo page, then paste it in a plain text editor and reupload to your website. There are several lines like this:



document.write('<div><img name="defaultslide'+this.slideshowid+'" src="'+this.postimages%5b0%5d.src+'"></div>')


which should look like this:



document.write('<div><img name="defaultslide'+this.slideshowid+'" src="'+this.postimages[0].src+'"></div>')


in your code.

Hope this helps.

jscheuer1
02-22-2008, 06:00 PM
I had actually replied to this earlier with the same info about the code, but the forum trashed my message for some reason. There are in fact several places in your code where characters that should be literal are represented by their %hex entities. These changes may be the result of your method of uploading the file, or something your editor did to it. Best to use a text-only editor like NotePad, and to upload the file via FTP in binary mode.

jscheuer1
02-22-2008, 06:21 PM
This is actually a duplicate of a portion of another thread, and things have progressed further there, closing this thread.

Here is the active thread:

http://www.dynamicdrive.com/forums/showthread.php?p=131719#post131719