PDA

View Full Version : HV Menu + Lightbox image viewer



Aradon
02-20-2008, 09:54 AM
1) Script Title: HV Menu + Lightbox image viewer 2

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm + http://www.dynamicdrive.com/dynamicindex1/hvmenu/index.htm

3) Describe problem: I'm using these two scripts on one page as can be seen at http://www.ryanscarry.com/portfolio_macro.htm all is well, however when an image is opened via the gallery, the menu sits on top of the overlay. Anyway i can force the menu to stay behind the gallery?

Also I cant seem to get the "rev" function to work, so that I can link the captions to a URL

Thanks

jscheuer1
02-20-2008, 04:32 PM
In the lightbox.css file, multiply all three z-index property values by 10 (append a 0), ex:


#lightbox{
position: absolute;
left: 0;
width: 100%;
z-index: 100;
text-align: center;
line-height: 0;
}

becomes:


#lightbox{
position: absolute;
left: 0;
width: 100%;
z-index: 1000;
text-align: center;
line-height: 0;
}

Aradon
02-27-2008, 08:50 AM
Awesome, that did the trick nicely, any ideas why the rev function wont work? Or the picture caption function?

Cheers!

jscheuer1
02-27-2008, 09:16 AM
I see no attempt to use the rev attribute in your lightbox links, but notice that the titles are not showing up in the enlarged lightbox. That's because of this style:


span {
display: none;
}

in your style.css file. This is probably also preventing any link you might try to make using the rev attribute from showing up either.

Aradon
02-27-2008, 12:34 PM
Thanks, what should i do to get around this then?

EDIT:

NVM, just removed it and it works a treat now, thank you VERY much John :)

bioxnet
04-10-2008, 03:39 PM
hi im having the same problem... i tried z-index to 1000 and that worked,
BUT now i cant seem to have the menu under the lightbox dim.

any clues?

www.biioxnet.com

thanks
G

bioxnet
04-10-2008, 09:16 PM
hi just want to post a thread that is a great tip to solving this. problem solver www.biioxnet.com
--------------------------

the link to the script in question, HVMenu: http://www.dynamicdrive.com/dynamici...menu/index.htm

I solved the problem tweaking the menu script itself (menu_com.js). There is a variable that controls the z-index of the menu on the line 31:

var Ztop=100;

I lowered the value to 50 and it worked. I didnt touch anything on the Lightbox scripts/css. Lightbox can be found here: http://www.dynamicdrive.com/dynamici...box2/index.htm