PDA

View Full Version : SWFOBJECTS 2.0 - Help



me_myself
02-08-2008, 03:04 PM
I downloaded the latest version of SWFOBJECTS 2.0 (embedding swf in html) from Google Code. I followed the instruction given there

Following is the code is used in the html head -

<script type="text/javascript" src="javascripts/swfobject.js"></script>
<script type="text/javascript">
swfobject.registerObject("topNav" , "8.0.0", "flash/expressInstall.swf");
</script>

Following is the code i used in the body -

<object id="topNav" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="676" height="145">
<param name="movie" value="flash/tn_home.swf" />
<param name="menu" value="false" />
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="flash/tn_home.swf" width="676" height="145">
<param name="menu" value="false" />
<!--<![endif]-->
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>

My problem is, even after doing all this, i still get the "click to activate" thing in IE 7 - i need to click on the navigation once to enable it and click on it again to go to the link page.

I need to know how to show my swf files in IE7 without the 'click to activate' thing - like firefox.

Thanks in advance.

jscheuer1
02-08-2008, 03:43 PM
Yeah, I just downloaded all that junk and followed the instructions and couldn't get it to work either. I mean, the Flash worked fine, it just didn't get rid of 'click to activate'.

I don't generally use swfobject though, so there might be something I'm missing. I use a completely different approach:

http://home.comcast.net/~jscheuer1/side/click_to_activate_w.htm

Works well for me and many others.

me_myself
02-08-2008, 03:54 PM
Thanks jscheuer1.

I downloaded an update for my dreamweaver 8 - 8.0.2. They have a small popup which opens if you have a flash in the page and fixes it. I no longer see the 'click to activate' after applying it.