PDA

View Full Version : Conveyer script adds all the images under eachother then slides them left to right



williamstam
01-31-2008, 07:44 AM
1) Script Title: Conveyor Belt slideshow script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

3) Describe problem:

hi i hope somone can help. ive been trying to find a slide show script that does exactly what this one does.. this is the only one i can find.

ive added the script to a page. when viewed with no other scripts the slide show works well. when i add the rest of the page all the images apear under eachother then slide left right like normal but the images dont fill the space next to eachother.

http://xs223.xs.to/xs223/08054/slideshow229.jpg

i hope somone can help.. :P

regards

william

jscheuer1
01-31-2008, 03:20 PM
To be certain of the problem, I would need a link to your page. But it looks like you have something introducing line breaks into the image train. Most likely this is something like:


img {
display:block;
}

in your stylesheet.

If that, or similar is the cause, this should fix it:


#test2 img, #test3 img {
display:inline;
}

If you need more help:

Please post a link to the page on your site that contains the problematic code so we can check it out.

williamstam
01-31-2008, 10:11 PM
ok... next question... do you ever sleep? CAN you sleep? that you're able to sort out problems like that so quickly... i was expecting to wait like a month, give up on the script and move on..

yes that was EXACTLY the problem.... thanks a billion for your help. you just saved me re doing an entire project

williamstam
01-31-2008, 10:16 PM
on a diferent issue... the slide show doesnt occure fluidly. like in...

the last picture apears then theres a gap about 1.5 times the width of the pictures then sudenly the first one apears in the right place next to the last 1. i saw a similer post somewhere else but no replies to it

its not so much a problem just a bit disturbing

regards

william

jscheuer1
01-31-2008, 10:30 PM
That one isn't going to be quite so easy for me. I would need to see it, more specifically have a link to a page that shows it happening, so I could examine the source code and see how it reacted to changes I might make to it. Also, if this happens only in a particular browser, or if you are only using a particular browser to test in, I would want to know the browser, its version and the OS you are using.

Please post a link to the page on your site that contains the problematic code so we can check it out.

williamstam
02-02-2008, 12:52 PM
hmmm... ok i need to just finish up some of this server side scripts (otherwise it wont work) then gonna save as the page and upload it.. its like that in opera, ie, firefox using XP pro.

williamstam
02-02-2008, 01:00 PM
ok so i made a "demo" of it... rather than try get the entire page to load (im having trouble getting the blasted ajax load content part to work so its throwing all kinds of errors for now)

so heres the link to the slide show part


http://www.press-store.co.za/store/aws/slideshowdemo/

thanks for the help :)

jscheuer1
02-02-2008, 02:18 PM
Your image train isn't long (wide) enough to fill the space you have set for it here:


var sliderwidth="273px"

This would work:


var sliderwidth="223px"

or you could double the array of images:


//Specify the slider's images
var leftrightslide=new Array()
var finalslide=''
leftrightslide[0]='<a href="http://"><img src="071003153013.jpg" alt="(photo)" width="50" border="0"></a>'
leftrightslide[1]='<a href="http://"><img src="071004150002.jpg" width="50" border="0"></a>'
leftrightslide[2]='<a href="http://"><img src="071009112635.jpg" width="50" border="0"></a>'
leftrightslide[3]='<a href="http://"><img src="071009113424.jpg" width="50" border="0"></a>'
leftrightslide[4]='<a href="http://"><img src="071003153013.jpg" alt="(photo)" width="50" border="0"></a>'
leftrightslide[5]='<a href="http://"><img src="071004150002.jpg" width="50" border="0"></a>'
leftrightslide[6]='<a href="http://"><img src="071009112635.jpg" width="50" border="0"></a>'
leftrightslide[7]='<a href="http://"><img src="071009113424.jpg" width="50" border="0"></a>'

Alternatively, just adding another image or two to the current array would also give the 'train' enough width to fill out your slide show.

williamstam
02-04-2008, 10:43 AM
LMAO... you cant be serious??? that that is all thats wrong with it? ....

wow.. thanks.. i feel like a complete idiot.

respect :)