PDA

View Full Version : HV Menu 5.5 Failing Under Firefox [Online]



Ellis
12-27-2007, 05:22 PM
1) Script Title:
HV Menu 5.5 (latest revision)
2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex1/hvmenu/index.htm
3) Describe problem:
Script works fine in both Firefox and IE in test mode on my hard drive. When I upload it to the website, nothing appears at all. I've checked the options in Firefox to allow javascript but that makes no difference. All files and folders were uploaded correctly. So ...does anyone know why this script should fail? Thanks.

molendijk
12-27-2007, 06:32 PM
Do you have a link for your site?

Arie Molendijk

Ellis
12-27-2007, 07:11 PM
Yes, it's www.hawkwoodbooks.co.uk. I've checked the error console and cleared a few declaration warnings but there's one "uncaught exception:permission denied to get HTML document.body"

Ellis
12-27-2007, 07:20 PM
I'm thinking this might be something to do with the HTML doctype. I use transitional but perhaps I should change this to "strict". I'm going to do this now and see what happens....

jscheuer1
12-27-2007, 09:15 PM
I'm thinking that it has to do with access across more than one domain to objects on pages is disallowed in most modern browsers. I couldn't get the menu to show up on that page in any browser. What browser and version does it work in? On what platform (OS - Mac, PC, other)?

Ellis
12-27-2007, 10:34 PM
I use FF2 but the menu works fine with IE in test mode locally but when uploaded it doesn't show on either. I tried the "strict" addition but it made no difference. Is this problem beatable do you think or should I look for another menu system? If it's the latter could you recommend one?
Thanks
Ellis

Ellis
12-31-2007, 08:08 PM
Thanks for the message outside of the forum. I don't use frames and didn't manage to solve the problem so decided to find another menu/navigation system which works fine. I'll leave it there now.
All the best.