View Full Version : prev, next button won't show, but links work fine. what is happening?

12-15-2007, 09:32 PM
i read all the comments on prev and next button not showing up but none of them solved my problem.

My real problem is that I don't see the next.gif and prev.gif button show up. My mouse turns into a hand when I go 50% or more to the right. I'm also able to click on it and itll take me to the next picture. The same thing happens with my prev.gif. But I DONT SEE THE IMAGES. I tried going into .css file and re-routing the "prevlabel.gif" and "nextlabel.gif" to correctly point to the right folder, but nothing changed.

I'm able to switch between pics by clicking the image(when my mouse changes from an arrow to a hand) but I can't see the images for "prev" and "next"

Can anyone help me PLEASE!.

Here is my code from lightbox.css.
hope this helps

position: absolute;
left: 0;
width: 100%;
z-index: 100;
text-align: center;
line-height: 0;

#lightbox a img{ border: none; }

position: relative;
background-color: #fff;
width: 250px;
height: 250px;
margin: 0 auto;

padding: 10px;

position: absolute;
top: 40%;
left: 0%;
height: 25%;
width: 100%;
text-align: center;
line-height: 0;
position: absolute;
top: 0;
left: 0;
height: 100%;
width: 100%;
z-index: 10;
#imageContainer>#hoverNav{ left: 0;}
#hoverNav a{ outline: none;}

#prevLink, #nextLink{
width: 49%;
height: 100%;
background: transparent url(..lightbox 2/images/blank.gif) no-repeat; /* Trick IE into showing hover */
display: block;
#prevLink { left: 0px; float: left;}
#nextLink { right: 0px; float: right;}
#prevLink:hover, #prevLink:visited:hover { background: url(..lightbox 2/images/prevlabel.gif) left 15% no-repeat; }
#nextLink:hover, #nextLink:visited:hover { background: url(..lightbox 2/images/nextlabel.gif) right 15% no-repeat; }

font: 10px Verdana, Helvetica, sans-serif;
background-color: #fff;
margin: 0 auto;
line-height: 1.4em;
overflow: auto;
width: 100%

#imageData{ padding:0 10px; color: #666; }
#imageData #imageDetails{ width: 70%; float: left; text-align: left; }
#imageData #caption{ font-weight: bold; }
#imageData #numberDisplay{ display: block; clear: left; padding-bottom: 1.0em; }
#imageData #bottomNavClose{ width: 66px; float: right; padding-bottom: 0.7em; }

position: absolute;
top: 0;
left: 0;
z-index: 90;
width: 100%;
height: 500px;
background-color: #000;


12-15-2007, 09:48 PM
sorry, heres my website, it'll show you what im talking about. click on the 3d models link to your right. it'll take you straight to the images and click on the first image.

12-16-2007, 05:50 PM
*bump*, can someone help me please?

12-16-2007, 06:11 PM
These paths:

#prevLink:hover, #prevLink:visited:hover { background: url(..lightbox 2/images/prevlabel.gif) left 15% no-repeat; }
#nextLink:hover, #nextLink:visited:hover { background: url(..lightbox 2/images/nextlabel.gif) right 15% no-repeat; }

are invalid. They could be:



If those paths to the images are accurate relative to the stylesheet file. When in doubt, best to use the absolute path. There could be other problems. If you need more help:

Please post a link to the page on your site that contains the problematic code so we can check it out.

12-16-2007, 10:03 PM
ya, sorry I forgot to post my website on the last post.

here it is,


if you go to the "Webdesign" link and click on the FIRST IMAGE ONLY. you'll see what I'm talking about or you can view the source code.

either way.


12-16-2007, 10:30 PM
this is weird........

I'm using smartFTP and I'm having some issue with the file transfer.....

when I transfer my file on to the server I get this issue

257 "/httpdocs" is current directory.
[16:22:14] Remote file exist check: "hg3d_3DMODELS.html".
[16:22:14] TYPE I
[16:22:14] 200 Type set to I
[16:22:14] SIZE hg3d_3DMODELS.html
[16:22:14] 213 24764
[16:22:14] MDTM hg3d_3DMODELS.html
[16:22:14] 213 20071216220258
[16:22:14] No rule matched. Default Action="Ask".
[16:22:19] PASV
[16:22:19] 227 Entering Passive Mode (128,121,20,240,244,239).
[16:22:19] Opening data connection to Port: 62703
[16:22:19] STOR hg3d_3DMODELS.html
[16:22:20] 150 Opening BINARY mode data connection for hg3d_3DMODELS.html
[16:22:20] 24764 bytes transferred. (51.6 KB/s) (468 ms)
[16:22:20] 226 Transfer complete.
[16:22:20] MDTM 20071216205034 hg3d_3DMODELS.html
[16:22:20] 550 20071216205034 hg3d_3DMODELS.html: No such file or directory <------this is what bothers me!!
[16:22:20] SIZE hg3d_3DMODELS.html
[16:22:20] 213 24764
[16:22:20] TYPE A
[16:22:20] 200 Type set to A
[16:22:20] PASV
[16:22:20] 227 Entering Passive Mode (128,121,20,240,193,54).
[16:22:20] Opening data connection to Port: 49462
[16:22:21] LIST -aL
[16:22:21] 150 Opening ASCII mode data connection for file list
[16:22:21] 1424 bytes transferred. (17.8 KB/s) (78 ms)
[16:22:21] 226-Transfer complete.
[16:22:21] 226 Quotas off
[16:22:21] Transfer successful.

this problem is....I am able to see the updates I made after I transfer my .html file onto my server. To test it I tried to delete a lot of images on my web design page and after saving it I transferred it to my server. It gave me the same "550 no such file or directory" error and at the end of the line it also said "Transfer successful" just like you see above. When I went to my website I was able to see the changes. Which means that the file transfer is working.

So I transferred all the necessary files, images, .html's etc for my 3d models page and they all gave me the same 550 error, but this time when I went to my website and clicked on an image from 3d models, nothing happend. It just keeps loading forever. I don't understand that part. If you go on to my webpage www.hgarcia3d.com and go to 3d models and click on any image, then youll notice that it keeps onloading forever. I transferred EVERY SINGLE file, image, etc I could think of, onto the server. But it still gives me the same result.

Can anyone offer any solutions.
Sorry for the long message, but I had to explain it in detail so you could understand.


12-17-2007, 04:53 AM
OK, first the hg3d_WEBDESIGN.html page and its css. The paths to the images are now correct. Your HTML syntax on the page:


is incorrect for a grouping of images though. You need to also use a bracketed group name and apply the same name to all of the links in the group:


would be appropriate. Change all rel="lightbox" to rel="lightbox[webdesign]" and you should be in business as far as that goes.

Now, I have no experience with an FTP program giving so much information, so I cannot help too much with that part. But the file:


is simply not there. In fact, the directory:


is not there.