PDA

View Full Version : anylink drop down menu & z-index problem..



novoluz
12-04-2007, 08:26 AM
1) Script Title: anylink drop down menu

2) Script URL (on DD): http://dynamicdrive.com/dynamicindex1/dropmenuindex.htm

3) Describe problem:

Ok, the menu works great, but i'm having 1 minor problem.
The dropdown menu is going behind a video clip that i set up.
I tried changing the z-index on the menu, but it didn't work.
Check out this link to see what I'm talking about:
http://nov-exl.com/test

Any advice will be gladly appreciated.
Thanks,
Cesar

ddadmin
12-04-2007, 10:51 AM
This has been discussed many times on the forums before, please try doing a search. There are quite a few different techniques for overcoming this.

novoluz
12-05-2007, 05:32 PM
I did a search, but all I found was a solution for the menu when it goes behind Flash movies. What I have instead is a regular movie (wmv file). Please help!

Thnx,
c

novoluz
12-09-2007, 11:50 AM
*bump*

jscheuer1
12-09-2007, 06:31 PM
If it is a Flash Video clip:


Follow the detailed information at:

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14201

Or, if this short version (good in most cases) fixes it, so much the better! Add in this language to your object/embed tag:

Add the following parameter to the OBJECT tag:

<param name="wmode" value="transparent">

Add the following attribute to the EMBED tag:

wmode="transparent"

Or, if you are using two object tags, as can and is sometimes done, add the param tag to both of them.

If you are using script to generate the tags (as is frequently done to avoid the 'click to activate' feature in some browsers), the wmode transparent must be passed to the script. This is easily accomplished but, varies depending upon the sort of script one uses. Some scripts do it automatically.

If not, there may not be a way.