PDA

View Full Version : Thumbnail Viewer II + Ultimate Fade-In Slideshow



hgisch
11-28-2007, 04:58 AM
1) Script Title: a)Thumbnail Viewer II and b)Ultimate Fade-In Slideshow
2) Script URL (on DD):
a) http://www.dynamicdrive.com/dynamicindex4/thumbnail2.htm
b) http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

3) Describe problem:
I am using both scripts on the same page. An old version of Thumbnail Viewer II was used until now and both scripts worked ok.
Upgrading to thumbnail viewer v1.51 the thumbail viewer does not work anymore on mouseover in IE 6+7, fadeshow still ok. It does work on FF and the new thumbnail viewer does work on a page by itself in IE versions.

appreciate some help on this.

jscheuer1
11-28-2007, 06:13 AM
Please post a link to the page on your site that contains the problematic code so we can check it out.

hgisch
11-28-2007, 06:37 AM
This is the testing site:
http://www.helpit.com.au/helpit_new/index_dev.php
rgds,
Hans

jscheuer1
11-28-2007, 06:58 AM
I've seen this happen before with the thumbnailviewer script on pages with a lot of other scripts on them.

I made a local copy and removed the defer attribute. Then both scripts functioned. Remove the red part:


<script type="text/javascript" src="thumbnailviewer2.js" defer="defer">

/***********************************************
* Image Thumbnail Viewer II script- Dynamic Drive DHTML code library (www.dynamicdrive.com)
* Visit http://www.dynamicDrive.com for hundreds of DHTML scripts
* This notice must stay intact for legal use
***********************************************/

</script>

This defer business is a good way to do a quick onload event in IE without using up an event handler, but when there are a lot of other things going on with the page, I've seen it cause problems.

hgisch
11-28-2007, 11:30 AM
Thanks John,
removing the defer option fixed it.

all the best,

Hans