PDA

View Full Version : css help



Chadi
10-24-2007, 02:20 AM
1) Script Title: FF1+ IE5.5+ Opr8+
Ajax Tabs Content Script (v 2.0)

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/

3) Describe problem:

See attached. The one with the missing right border (right side of the words "refresh" and "profile") is in IE7. The one with the right border intact is Firefox 2. Why is it missing in IE7?

Also, the tabs (4) show a bit vertically smaller in IE7 than Firefox. Any workaround for this?

I attached the css file too.

This is the entire html of my vbulletin forumhome template
http://pastebin.com/m3ca2aa7a

The missing right border in IE7 is coming from the cbox (shoutbox) frame area around this portion of the html


#
#
</td></tr><tr>
#
<td align="center">
#
<if condition="in_array($bbuserinfo['usergroupid'], array(2,6,7,25))">
#
<iframe frameborder="0" width="100%" height="60" src="http://www.cbox.ws/box/?boxid=439&amp;boxtag=7868&amp;sec=form&amp;nme=<?=urlencode($username)?>&amp;nmekey=<?=md5('1j3n8ei6mo4j2g40'.$username)?>&amp;wname=75&amp;wemail=68&amp;wmsg=250" marginheight="1" marginwidth="1" scrolling="no" allowtransparency="yes" name="cboxform" id="cboxform" style="border: 1px solid #E4E6F5"></iframe>
#
<else />
#
You must be logged in and registered to use this shoutbox
#
</if>
#
</td></tr>
#
</table>
#
</div>
#
<!-- END CBOX -->

I also cannot get vbradio to work. It normally opens up a pop window, but because the ajax content is in its own directory (ajaxtabs)
I had to readjust the link.

The regular code that did work in non-ajax mode was this


<script type="text/javascript">
<!--

function OpenRadio(){
Radio = window.open('vBRadio.php','vBRadio','directories=no,height=320,width=650,location=no,menubar=no,resizable=no,status=no,toolbar=no')
return false;

}
-->
</script>
<a href="#" onclick="return OpenRadio()">

I changed vBRadio.php to show ../vBRadio.php and even tried /vBRadio.php but none of these methods work.

vBRadio.php is in the root folder of the forum itself. ajaxtabs is just a sub-directory so I'm confused why its not working.

ps: its not my popup blocker either ;)