PDA

View Full Version : Scrolling Iframe Using Graphics Doesn't work with ASP



diskodowg
04-21-2005, 06:55 PM
Hello. I've run into a small dilemma. I downloaded the java to scroll through an iFrame on a site i'm working on and it works great except when the iFrame contains .asp pages. HTML and HTM works fine, but for whatever reason, the .asp won't let it scroll at all (except for some reason on mac's ie browser).

A friend of mine said the script returned the following error and he was trying to help, but i thought i'd come to the source for some help.

...Error: uncaught exception: Permission denied to get property Window.scrollBy

Any and all help would be greatly appreciated.

Arctic Fox
04-24-2005, 07:12 AM
Well, let's see your code; the one on the actual page as well as the code you're putting on the .asp page that goes into the iFrame...

diskodowg
04-25-2005, 09:49 PM
the page with the java is at www.kidsintheway.com/new

if you click on the link "tour" on the menu on the left, you'll see the .asp page populate the iframe and it will not scroll.

Thanks for writing back!

Arctic Fox
04-26-2005, 12:57 AM
Hmmm, I'm not quite understanding how this works.

There's a difference in your SRC JS:
Bio: <script language="javascript" src="/new/lib_js/global.js"></script>
Etc: <script language="javascript" src="./lib_js/global.js"></script>

But I can't tell if your JS has anythig to do with the scroller...


In your Journal page, I recognize "Scrollable content III", but I don't see the first part of that script on your 'new' page - it's a different script.

Options:

try changing the SRC of your JS to match your Bio page and see if that does anything.
I would suggest you stick with the "Scrollable content III" for all your pages. (I've something similar on my site that you're welcome to copy).

Let me know what works or doesn't work and I'll see what else I can find. :)

diskodowg
04-26-2005, 01:22 PM
we've already checked that and it's not the problem. for some reason the java just doesn't recognize the .asp. one of my friends who's trying to help me figure it out is thinking it's a java error still since he's getting an error message.

any more ideas?

Arctic Fox
04-27-2005, 12:53 AM
Error on line 43.
Line 43 <body onLoad="MM_preloadImages('layout/scroll_r2_c1_f2.jpg','layout/scroll_r4_c1_f2.jpg')">

I'm not sure if that has something to do with it, though...

If this was me, I'd remove all the scroller scripts and either start over, or just use the scrolling script from my site and see what happens.

I'm sorry, I don't know what else could be the problem since I've no experience with asp, I'm kind of in the dark on that part.

Mikey
05-03-2006, 12:25 AM
I've got the same problem, though its running on a Tomcat server.

The funny thing is though, the code used to work. Previously it was on a JRun server, running fine. I'm migrating the app to tomcat and i get the exception error.

Mikey
05-03-2006, 12:59 AM
I worked out what my issue was. When i migrated the framset was pointing to one local frame and one frame on the old server. It would seem that you can't do that and still expect them to scroll.

Hope that helps.