PDA

View Full Version : null pointer exception using <html:javascript>



a_jos
10-03-2007, 08:16 AM
hi all,
im getting some problems in my javascript validations.....
my jsp code-->



8: <head>
9: <title>Budget Master Administration</title>
10: <meta name="GENERATOR" content="Microsoft FrontPage 3.0">
11: <html:javascript src="bscript.js" method="everything(this)" staticJavascript="false"/>
12: <!-- <SCRIPT LANGUAGE="JavaScript" SRC="bscript.js">
</SCRIPT> -->
13: <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
14: </head>


the exception that im getting is-->



SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.NullPointerException
at org.apache.struts.taglib.html.JavascriptValidatorT ag.doStartTag(JavascriptValidatorTag.java:316)
at org.apache.jsp.pages.admin.addbdgt_jsp._jspx_meth_ html_005fjavascript_005f0(addbdgt_jsp.java:157)
at org.apache.jsp.pages.admin.addbdgt_jsp._jspx_meth_ html_005fhtml_005f0(addbdgt_jsp.java:120)
at org.apache.jsp.pages.admin.addbdgt_jsp._jspService (addbdgt_jsp.java:91)
at org.apache.jasper.runtime.HttpJspBase.service(Http JspBase.java:98)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:803)
at org.apache.jasper.servlet.JspServletWrapper.servic e(JspServletWrapper.java:328)
at org.apache.jasper.servlet.JspServlet.serviceJspFil e(JspServlet.java:315)
at org.apache.jasper.servlet.JspServlet.service(JspSe rvlet.java:265)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:803)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:210)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:174)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:117)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:108)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:151)
at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:870)
at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:665)
at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:528)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:81)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:685)
at java.lang.Thread.run(Unknown Source)



whats wrong with this ...plz throw some light on this...
regards,
a_jos