PDA

View Full Version : IFrame SSI script II submission using a Form



pigsfoot
09-17-2007, 10:47 PM
Hi,

I have a questions regarding IFrame SSI script II

I use this script on my site to dynamically resize IFrames and it works very well.

I have the script working both on page loads and also std links.

I have run into a problem calling the script from a form submit.

If i don't use the script my Form links work no problem using the code below

<form name="mojo" method="get" action="http://www.smovemove.co.uk/estate/cgi-bin/mojoEstate.cgi?mojo=1">
<input type="hidden" name="type" value="search">
<input type="hidden" name="action" value="search">

I have tried the following change ( action line )

<form name="mojo" method="get" action="javascript:loadintoIframe('mainframe', 'http://www.smovemove.co.uk/estate/cgi-bin/mojoEstate.cgi?mojo=1')">
<input type="hidden" name="type" value="search">
<input type="hidden" name="action" value="search">

the result is a new page loaded but with no results.

I presume I have used the wrong syntax somewhere and entered the code wrong as there is nothing else that I can think of that would stop it working, all I want to be is load the results into my Iframe….which I presume should be pretty straight forward.

Any suggestions would be very much appreciated.

Thanks....Pigsfoot

pigsfoot
09-25-2007, 07:30 PM
If anyone has any idea where i may be going wrong with this it would be very much appreciated.

I presume i have just entered my code in the wrong place within the form code, i'm just not sure where it should go.

Thanks...Pigsfoot