PDA

View Full Version : Setting Up A My SQL Database



Rockonmetal
09-02-2007, 12:54 AM
Ok, some people might remember this post, I BROUGHT IT BACK TO LIFE!!!! MUAHAHAHAHA!! ok enough with the drama... heres what I got:
Computer with wamp5...
Internet connection
Dummies book for PHP & MySQL Everyday Apps
Thats all i got...
I tried to do this on my own before and I failed horribly
I am unfortunitly one of those people who ask for step by step directions *meaning a lot of detail in english not the language i attempt to learn*
Thanks!
I just need someone to help me get MySQL to work

jr_yeo
09-02-2007, 02:07 AM
what do u want MySQL to do?

Rockonmetal
09-02-2007, 02:55 AM
Uh, i just want to be able to log into my control panel using wamp5

alexjewell
09-02-2007, 12:25 PM
http://www.php-mysql-tutorial.com/

Rockonmetal
09-02-2007, 07:34 PM
Unfortunitly that link was not very helpful because it made no sense at all... and its not making any sense... just wat are the steps so i can get a MySQL database to work... I have WAMP5 on my computer and the only thing i did was run the installer. When i click phpadmin or SQLiteManager it does nothing... how do one of those to work... If i need to download other stuff please give the links to it...

thetestingsite
09-02-2007, 07:38 PM
You may need to reinstall WAMP5 if the links and whatnot aren't working. To my understanding, MySQL is installed when you install WAMP5; if it doesn't, then you may need to redownload the installer and try again or even try downloading another WAMP package (such as NetServer or Xampp).

Hope this helps.

Rockonmetal
09-02-2007, 08:33 PM
Note i have not read the manual or documentation to do the install... would that be a problem?

Rockonmetal
09-03-2007, 04:41 AM
I know that netserver gets me the phpadmin but I can't view my site from the www folder...

jr_yeo
09-03-2007, 02:43 PM
1. do u see something like this in ur control panel? (see attached file named pic1.jpg)

2. do u see something like this in the lower right side of ur computer? (see attached file named pic2.jpg). emphasis on the middle icon.

Rockonmetal
09-03-2007, 05:04 PM
yeah, i see both of those when i have wamp5 on... but i can't get to phpadmin or sql lite...

jr_yeo
09-04-2007, 12:50 AM
even after clicking the link PHPmyadmin, u dont see something like the attached file?

Rockonmetal
09-04-2007, 01:03 AM
no i don't I see something like this

jr_yeo
09-04-2007, 01:09 AM
ok... try to re-install wamp5 or better yet download again the wamp5 package

Rockonmetal
09-04-2007, 01:22 AM
I have done that many times... but i will yet again, try again lol...

jr_yeo
09-04-2007, 01:29 AM
please check if u got httpd.exe and mysqld-nt.exe installed.

Rockonmetal
09-04-2007, 01:35 AM
mysql-nt.exe at 956kb, no change for 2 minutes
httpd.exe there is 2 versions running and i accidently deleted the lesser one... woops!
i tried to install via wamp but it isn't working... i can't reach localhost...
I'm gonna re-download and reinstall...

jr_yeo
09-04-2007, 01:41 AM
ok... make sure to restart ur computer after installing the wamp5 and tick the "Launch Wamp5 as a service" thingie... :p

Rockonmetal
09-04-2007, 01:56 AM
Launch Wamp5 as a Service????
where is that???

jr_yeo
09-04-2007, 01:59 AM
i forgot where it is, actually...

but if u dont see it, then forget about it then...

Rockonmetal
09-04-2007, 02:39 AM
k... i installed, restarted my computer and what do I do now...

*P.S* i have already checked phpMyadmin and its now saying

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

shagura
09-04-2007, 09:25 PM
It sounds like you need to uninstall the whole lot and start again buddy.

So uninstall WAMP first, reboot and run CRAP CLEANER (http://www.ccleaner.com/) to delete traces of the WAMP installation and then I would try reinstalling or use what I am using: Web Developer Suite (http://www.devside.net/server/webdeveloper) it's essentially a WAMP just like you have now, but it's a one-click install process with very few things you can f#ck up. It took me five minutes to have a database up and running after that.

I haven't time to type out exact instructions for that part just now, but I hope the above helps ya out.

Rockonmetal
09-04-2007, 09:52 PM
It doesn't work... I tried it, its a peice of nothing man... the manual just says to buy the pro version... I need to know how to do this soon... So I'm now looking how to do this on WAMP5
Please
GIVE INSTRUCTIONS ON WHAT TODO!
Like this:
Install Program
Restart Computer
Open up wamp
Change some stuff
Etc...
Basicly I don't know what to do!
Thanks to anyone who helps

jr_yeo
09-05-2007, 07:26 AM
here's a thought...

maybe u have conflicting programs using TCP port 3306 :cool:

i don't know what else to suggest... coz i have never encountered problems while installing and using wamp5 :D

Rockonmetal
09-05-2007, 06:46 PM
ok, how do you check if there is a conflicting program with port 3306...
I have to edit some files right to get this thing going? if so what do I edit and where...

Thanks

jc_gmk
09-07-2007, 01:50 PM
Insted of WAMP5 give XAMPP a go!
http://www.apachefriends.org/en/xampp.html

I've used it for ages without any problems. :)

Rockonmetal
09-11-2007, 09:40 PM
I've tried XAMPP a go but its just not user friendly enough for me...
All I need is for someone to tell me how to do this on WAMP5!
My Goal:
Get a mysql database up and opperational...

Background information:
Computer type: laptop
Computer Company: Gateway
Date Computer was recieved: 2003
Times computer has crashed: 3 *its the 1 year and 1 month anniversery of the 3rd time!*

Ok that should help *I think*
thanks!

thetestingsite
09-11-2007, 09:51 PM
The thing about this is that it SHOULD work right out of the box. Unfortunately, it's not doing so for you. When I get home I'll download and install WAMP5 on my computer to see if perhaps there is something that you need to do to get it set up and working, but my experience is that it should work "out of the box".

Hope this helps.

thetestingsite
09-11-2007, 10:26 PM
Quick question. On the WAMP icon in the taskbar (on the computer), does the icon have a yellow color or is it white? If it is yellow, click on the icon and it should bring up the WAMP5 control panel menu. When it does, hover over "MySQL" and click on "Start Service". If that is grayed out, click on "Install Service" and that should fix it for you.

hope this helps.

//EDIT: You may also want to look at this link: http://wampserver.com/en/faq4.php

thetestingsite
09-12-2007, 01:26 AM
Sorry to triple post like this, but I have just tested out WAMP5. Here are the steps you need to take in order to set up MySQL on your install. Before starting, make sure you uninstall your current install as not to conflict with these instructions.


download the latest version of WAMP5 from the following link: http://www.wampserver.com/dl.php
Run the setup wizard and follow the on-screen instructions.
Once finished with the on-screen instructions in the setup wizard, click on the WAMP5 icon in the taskbar and click on the phpmyadmin link.
login using root with no password. (Change immediatly once logged in)


If you need any further help, let me know; but by default MySQL is installed and running. Also, you may want to look around their support forums for more info if you run into more problems.

Hope this helps.

Rockonmetal
09-12-2007, 05:50 PM
Thanks man I looked at the link to that page you gave me... unfortunitly I don't even
if i'm correct the on-screen instructions is

http://localhost/phpmyadmin/documentation.html
If not then what is it?

thetestingsite
09-12-2007, 05:54 PM
When you run the setup exe file, it prompts you for input towards the end. Mostly all you have to do is click "Next" and it will do the rest. When you go to phpmyadmin, do you get an error message? If so, what is the error.

Hope this helps.

Rockonmetal
09-12-2007, 06:06 PM
When you go to phpmyadmin, do you get an error message? If so, what is the error.
Yeah i do get an error message... its

phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

Its doesn't offer a link or anything... just the plain text above...
Thanks

thetestingsite
09-12-2007, 06:24 PM
Ok, then check the error logs in your apache/logs/ directory. From there you will be able to get the exact error message.

Hope this helps.

Rockonmetal
09-12-2007, 09:05 PM
ok i checked the error log for apache and the entries for today are this:



[Wed Sep 12 13:42:21 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.4 configured -- resuming normal operations
[Wed Sep 12 13:42:21 2007] [notice] Server built: Jan 9 2007 23:17:20
[Wed Sep 12 13:42:21 2007] [notice] Parent: Created child process 3316
[Wed Sep 12 13:42:22 2007] [notice] Child 3316: Child process is running
[Wed Sep 12 13:42:22 2007] [notice] Child 3316: Acquired the start mutex.
[Wed Sep 12 13:42:22 2007] [notice] Child 3316: Starting 250 worker threads.
[Wed Sep 12 13:42:22 2007] [notice] Child 3316: Starting thread to listen on port 80.
[Wed Sep 12 13:42:53 2007] [error] [client 127.0.0.1] PHP Notice: Undefined variable: mysql_version in C:\\wamp\\www\\index.php on line 179
[Wed Sep 12 13:43:19 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_iv0qgbdomkep49grqbad33eed0, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89
[Wed Sep 12 13:43:19 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_iv0qgbdomkep49grqbad33eed0, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[Wed Sep 12 13:43:19 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0
[Wed Sep 12 13:43:28 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_vhesjbqeab81om18p9ttdt0t46, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89
[Wed Sep 12 13:43:28 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_vhesjbqeab81om18p9ttdt0t46, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[Wed Sep 12 13:43:28 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0
[Wed Sep 12 13:43:35 2007] [error] [client 127.0.0.1] PHP Notice: Undefined variable: mysql_version in C:\\wamp\\www\\index.php on line 179
[Wed Sep 12 13:43:37 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_la0n01skgrkf5iephj933bb6r5, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\sqlitemanager\\index.php on line 8, referer: http://localhost/
[Wed Sep 12 13:43:38 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_la0n01skgrkf5iephj933bb6r5, O_RDWR) failed: No such file or directory (2) in Unknown on line 0, referer: http://localhost/
[Wed Sep 12 13:43:38 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0, referer: http://localhost/
[Wed Sep 12 13:43:41 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_ct03qsck7njo471ajecffq3pg5, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89, referer: http://localhost/
[Wed Sep 12 13:43:41 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_ct03qsck7njo471ajecffq3pg5, O_RDWR) failed: No such file or directory (2) in Unknown on line 0, referer: http://localhost/
[Wed Sep 12 13:43:41 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0, referer: http://localhost/
[Wed Sep 12 13:45:17 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_qs3411ig30u98l6vh9h4mhegj7, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89, referer: http://localhost/phpmyadmin/documentation.html
[Wed Sep 12 13:45:17 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_qs3411ig30u98l6vh9h4mhegj7, O_RDWR) failed: No such file or directory (2) in Unknown on line 0, referer: http://localhost/phpmyadmin/documentation.html
[Wed Sep 12 13:45:17 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0, referer: http://localhost/phpmyadmin/documentation.html
[Wed Sep 12 13:49:13 2007] [error] [client 127.0.0.1] PHP Notice: Undefined variable: mysql_version in C:\\wamp\\www\\index.php on line 179
[Wed Sep 12 14:02:45 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_tlr3jajbd9ikjg4pfopgrsjd64, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89
[Wed Sep 12 14:02:45 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_tlr3jajbd9ikjg4pfopgrsjd64, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[Wed Sep 12 14:02:45 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0
[Wed Sep 12 16:55:51 2007] [notice] Apache/2.2.4 (Win32) PHP/5.2.4 configured -- resuming normal operations
[Wed Sep 12 16:55:51 2007] [notice] Server built: Jan 9 2007 23:17:20
[Wed Sep 12 16:55:51 2007] [notice] Parent: Created child process 3392
[Wed Sep 12 16:55:52 2007] [notice] Child 3392: Child process is running
[Wed Sep 12 16:55:52 2007] [notice] Child 3392: Acquired the start mutex.
[Wed Sep 12 16:55:52 2007] [notice] Child 3392: Starting 250 worker threads.
[Wed Sep 12 16:55:52 2007] [notice] Child 3392: Starting thread to listen on port 80.
[Wed Sep 12 16:56:41 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_h2u0dfuu93jmojvji9e3s9ta61, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\phpmyadmin\\libraries\\session.inc.php on line 89
[Wed Sep 12 16:56:41 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_h2u0dfuu93jmojvji9e3s9ta61, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[Wed Sep 12 16:56:41 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0
[Wed Sep 12 17:01:30 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_u3in1crckoafcd5e2gj6lb34n4, O_RDWR) failed: No such file or directory (2) in C:\\wamp\\sqlitemanager\\index.php on line 8
[Wed Sep 12 17:01:30 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session\\sess_u3in1crckoafcd5e2gj6lb34n4, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[Wed Sep 12 17:01:30 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\OWNER~1.GAT\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0

Hope that that helps

thetestingsite
09-12-2007, 11:05 PM
Ok, in the phpmyadmin directory look for config.inc.php. In that file, look for the following:



/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = '';


Whatever the auth_type is set to, change it to 'cookie'. If it is already set to cookie, then it is a problem with the phpmyadmin. You may have to re-download it and install from scratch.

hope this helps.

Rockonmetal
09-12-2007, 11:38 PM
Yeah i do get an error message... its

phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.



I still get that error after I changed that line. It now reads:

$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)?

If you want I'm going to put that file up on my site so you can look it over...

i'll pm you the link to it... thanks!

thetestingsite
09-13-2007, 04:38 PM
I think you may need to re-download phpmyadmin by going to the following website:

http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.11.0-english.zip?download

Remove all of the files in your current phpmyadmin install, then replace them with the above download. From there, edit config.inc.php to what I posted before. As for the MySQL server not working, run a simple telnet to localhost on port 3306 and see if MySQL is running. If you get a response, it is; otherwise, it isn't.

Hope this helps.

Rockonmetal
09-13-2007, 09:06 PM
I read what you said above wrong, i thought you said uninstall it, delete remaining files then reinstall from that link... so now heres what I"m doing...
Redownloading wamp5 1.7.3
Then unless you say other wise I will delete PHPMYADMIN folder and replace it with the new one from the link you gave above...
I wish my internet connection was faster though...

thetestingsite
09-13-2007, 10:24 PM
You shouldn't have to re-download WAMP5, unless you are upgrading to the newer version; but since you are doing it anyway, oh well. After you finish the install, make sure that MySQL is running by opening the command prompt (Start > Run > cmd on Windows2000+) and typing the following:



telnet localhost 3306


If you get a response like the following:



Connecting to localhost...Could not open connection to the host, on port 3306: Connection failed


then mySQL is not running or not installed correcty. If you get a blank screen for a few seconds, then get a bunch of gibberish on the screen; then MySQL is up and running properly. I think if you install the newest version of phpmyadmin, your problems will be gone.

Hope this helps.

Rockonmetal
09-14-2007, 12:02 AM
k i'll try that!
I'll let you know how it goes in a couple of seconds

Rockonmetal
09-14-2007, 12:18 AM
HERES What i got!
The first one is what I typed in...
The second on is what I got...
I have replaced the old PHPMYADMIN with the new one (the one you linked above...)
Thanks

Plus i still get the

phpMyAdmin - Error

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.
when i do PHPMYADMIN...
Before you ask I will give you the error log for the MYSQL

InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
070913 20:06:29 InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
070913 20:06:30 InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 10 MB
InnoDB: Database physically writes the file full: wait...
070913 20:06:30 InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
070913 20:06:31 InnoDB: Started; log sequence number 0 0
070913 20:06:33 [Note] c:\wamp\mysql\bin\mysqld-nt.exe: ready for connections.
Version: '5.0.45-community-nt' socket: '' port: 3306 MySQL Community Edition (GPL)


Thanks man!

thetestingsite
09-14-2007, 01:42 AM
Well, looking at the attached images, it looks like MySQL is up and running just fine. I'm not sure what else to tell you as far as troubleshooting is concerned without actually seeing the install on the machine. If you have VNC (http://www.uvnc.com) or Windows Remote Desktop, I could help you out by logging into your computer; just let me know via IM and we can walk this through step by step.

Other than that, not sure what to say.

Hope this helps nonetheless.

Rockonmetal
09-14-2007, 01:49 AM
ok... I saw this file in PHPMYADMIN called Documentation... it says something about installation... i skimmed over it but it said something about putting some things in some files i think i got Windows Remote Desktop...

My MSN is
rockonmetal@hotmail.com