PDA

View Full Version : DD Script ok in FF but not in Internet Exploder!



M0ZLB
08-31-2007, 11:35 AM
Image Thumbnail Viewer

http://www.dynamicdrive.com/dynamicindex4/thumbnail.htm

Hi All,

Very, very new to this but I successfully incorporated the above into a test page, then looked around for a way of moving the images to anywhere I wanted on the page! So far so good and in FireFox everything works just as I hoped/expected.

However, in IE7 nothing works!

I inspected the code in IE7 to make sure nothing had changed but cant see any problems that way!

I wonder if anyone could give me any pointers as to how to overcome this issue?

Many thanks in advance

David

Ryan Fitton
08-31-2007, 11:44 AM
Although IE is very buggy and useless it should still make the script work, i tested the script on DD in IE7 and it worked perfectly, so i think it maybe somthing you have done.

Please have a look and see if the file path to:

thumbnailviewer.css
thumbnailviewer.js
loading.gif


Are all correct, if they are, please post your code so we can have a look. :)

M0ZLB
08-31-2007, 11:51 AM
Hi Ryan,
Thanks for your reply - as I said at the top I am extremely new to this and am not sure quite what I need to do here :)

So, here's the code (and it is probably not the best code ever written)
This works in FF



<html lang="en">
<head>
<title> testpage &raquo; Page 1 of 1 </title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta http-equiv="Content-Style-Type" content="text/css;">

<link rel="stylesheet" href="thumbnailviewer.css" type="text/css" />

<script src="thumbnailviewer.js" type="text/javascript">

/***********************************************
* Image Thumbnail Viewer Script- Dynamic Drive (www.dynamicdrive.com)
* This notice must stay intact for legal use.
* Visit http://www.dynamicdrive.com/ for full source code
***********************************************/

</script>

<style type="text/css"><!--
.f01 {font: 16px 'arial', helvetica, sans-serif;color:#000000; } -->
</style>
</head>
<body id="page" <p><a href="DSC_0191.JPG""rel="thumbnail"><div style="
top: 199;
left: 250;
position: absolute;
z-index:1;
visibility: show;">
<img src="DSC_0191.JPG" style="width: 60px; height: 50px" /></a></p></div>
<p><a href="DSC_0191.JPG""rel="thumbnail"><div style="
top: 135;
left: 225;
position: absolute;
z-index:1;
visibility: show;">
<img src="DSC_0191.JPG" style="width: 60px; height: 50px" /></a></p></div>


Test page
</div>
</body>
</html>

Ryan Fitton
08-31-2007, 12:01 PM
<html lang="en">
<head>
<title> testpage &raquo; Page 1 of 1 </title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta http-equiv="Content-Style-Type" content="text/css;">

<link rel="stylesheet" href="thumbnailviewer.css" type="text/css" />

<script src="thumbnailviewer.js" type="text/javascript">

/***********************************************
* Image Thumbnail Viewer Script- Dynamic Drive (www.dynamicdrive.com)
* This notice must stay intact for legal use.
* Visit http://www.dynamicdrive.com/ for full source code
***********************************************/

</script>

<style type="text/css"><!--
.f01 {font: 16px 'arial', helvetica, sans-serif;color:#000000; } -->
</style>
</head>
<body id="page" <p><a href="DSC_0191.JPG" rel="thumbnail"><div style="
top: 199;
left: 250;
position: absolute;
z-index:1;
visibility: show;">
<img src="DSC_0191.JPG" style="width: 60px; height: 50px" /></a></p></div>
<p><a href="DSC_0191.JPG" rel="thumbnail"><div style="
top: 135;
left: 225;
position: absolute;
z-index:1;
visibility: show;">
<img src="DSC_0191.JPG" style="width: 60px; height: 50px" /></a></p></div>


Test page
</div>
</body>
</html>

Try this

Ryan Fitton
08-31-2007, 12:02 PM
although i dont think it will work, because there is no hyperlink to the images

M0ZLB
08-31-2007, 12:28 PM
Ryan,

Thanks, it did work, I have just uploaded it and tested it in FF and IE and it does work although I noticed that in IE (only), there was no indication when the mouse rolled over the thumbnail that there was anything to click on although there was!

If you have a minute, could you explain what the issue was?

Thanks

David

Ryan Fitton
08-31-2007, 03:37 PM
The problem was u added an extra " in your code so i just took it out.

Below is an example of what i took out:

<a href="DSC_0191.JPG""rel="thumbnail">

I hope you understood what i have said, if u have not please reply to me

M0ZLB
08-31-2007, 03:48 PM
The extra " appears to be in the source code I think:

<p><a href="http://img201.imageshack.us/img201/6923/countryxb6.gif"" rel="thumbnail"><img src="thumbnail.gif" style="width: 50px; height: 50px" /></a></p>

which would explain why I didnt realise there was an error!

I wonder why that extra " fouls it up in IE but allows it to run in FF.

Anyway, many many thanks for your kind help!

David

jscheuer1
08-31-2007, 05:06 PM
Dealing with syntax errors in HTML is something all browsers do. However, since it is impossible to anticipate all potential errors and the correct remedy for each one, and because there are no standards governing error correction, not all browsers error correct in the same way.