PDA

View Full Version : Removing Autosuggest Textbox



ulrich
04-11-2005, 09:35 AM
Hei,

I would like to remove all text suggestions on my password textBox:

<asp:TextBox id="passwordTextBox" runat="server" TextMode="Password" Width="176px"></asp:TextBox>
When I dobbelt click on the textBox, I see all the entries :(
How can I disable this function?

Many Thanks

jscheuer1
04-11-2005, 03:59 PM
This is more a security issue for the individual user, I would think. Did you try clearing your cache and removing all cookies? I have noticed that with an input to a form, the 'name=' attribute will exhibit a similar behavior across all web based forms with that same input 'name=' attribute. A solution there is to use a unique name in one's form. This may apply to your 'id=' or, more likely, to your 'TextMode=' attribute. Anyways, is this really an HTML topic, or might it belong in the asp forum?

cr3ative
04-11-2005, 04:28 PM
Ah, I know what the OP means.

You need to reset your browser's Autocomplete memory, so have a look around it's documentation for how to do that.

cr3

ulrich
04-11-2005, 07:38 PM
Hi,

I have just read about Autocomplete Memory on this site: http://www.privacyeraser.com/features.htm

Autocomplete Memory
Internet Explorer (IE) can store a record of almost everything that you typed into any web site form. Form data can be things such as all the keywords you have ever typed into a search engine and personal information such as your name and address.

Do I need to download "Privacy Eraser Pro 4.02 1.95 MB" to solve this problem?

Thank you ;)

jscheuer1
04-11-2005, 08:46 PM
If you are that concerned with security, perhaps. However, I have autocomplete on and a bunch of other settings on and I don't get passwords suggested for me. I do still get history on forms, except the password, the key for me was answering no whenever windows offered to "remember your password for this page".