PDA

View Full Version : Lightbox



compmom
08-03-2007, 06:12 PM
1) Script Title: LightboxV 2.03

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:

I have used the script in Dreamweaver and it works well. The only item that I do not seem to be able to work out are the "Prev" and "Next" steps. They just do not appear anywhere on my image
I do not lnow where to include them if I need to enter them in the code.
The complete content of the script is in my "images folder"..

I was hoping someone could guide me on this.

P.S. I got the lightbox last week after posting for a search on this forum. It is a great script!!

Thanks

jscheuer1
08-03-2007, 06:29 PM
To get a 'group' that exhibits the previous/next feature, you need to add a group name inside of brackets [] to each rel="lightbox" attribute in that group:


<a href="image1.jpg" rel="lightbox[group1]">One</a>
<a href="image2.jpg" rel="lightbox[group1]">Two</a>
<a href="image3.jpg" rel="lightbox[group1]">Three</a>

Use the brackets. I say this because some people might think they are not for use in the actual code, but they are.

compmom
08-03-2007, 09:56 PM
Hi John: No I did not use the [group] attribute. I am using flowers images so I just used [flower] thinbking that it would be enough but I had no number next to it.
I am going to correct everything and post the results

Thanks for your help

Tina

compmom
08-04-2007, 03:00 AM
HI John: I tried your suggestion but I am not getting the "Next or "Prev.

This is the way I set up my code in Dreamweaver
<a href="images/image-1a.jpg" rel="lightbox[group1]<one>" title="lily"><img src="images/thumb-1a.jpg" width="110" height="146" /></a>
My Images are in a table

Everything else works fine.

I can change the css or enter a code if I have to;
I appreciate any help
Tina

compmom
08-04-2007, 03:07 AM
Sorry John : My code did not enclose the One in the <> as shown in my previous post . The code below is the one I used.
<a href="images/image-1a.jpg" rel="lightbox[group1]one" title="lily"><img src="images/thumb-1a.jpg" width="110" height="146" /></a>

Tina

thetestingsite
08-04-2007, 03:17 AM
Get rid of the highlighted part below and it should work:



<a href="images/image-1a.jpg" rel="lightbox[group1]one" title="lily"><img src="images/thumb-1a.jpg" width="110" height="146" /></a>


Hope this helps.

compmom
08-04-2007, 02:14 PM
HI John: I deleted the "one". I now get under the title the info image 1 of 9
and that is correct.
However the"Next and Prev little image tabs do not appear at all.
Is there any way that I can make them appear by inserting them in the code somewhere or changing the css? I can do that.

I am using dreamweaver and the images are in atable format. It works great otherwise.
I also tried by using Notepad to build the site with the same results.

Thanks for the help

jscheuer1
08-04-2007, 05:29 PM
I'm not sure what the problem is. It sounds like you haven't made the next/previous images available to the script and style in the folder where they expect them to be. But, as I say, I cannot be sure. I think that it is time, if you haven't already, to put up a live demo of your latest effort. Either way, give us a link to it.

Please post a link to the page on your site that contains the problematic script so we can check it out.

jbert
08-06-2007, 02:51 AM
Here is one of my sections, hope it helps

[code]
<img src="images/22.jpg" alt="" /><a href="macros/slides/1.jpg" rel="lightbox[macros]" title="Reversed Lily">Macros</a><br/>
<a href="macros/slides/2.jpg" rel="lightbox[macros]" title="Three Course Meal"></a>
<a href="macros/slides/3.jpg" rel="lightbox[macros]" title="Two against One"></a>
<a href="macros/slides/4.jpg" rel="lightbox[macros]" title="Cactus Bloom"></a>
<a href="macros/slides/5.jpg" rel="lightbox[macros]" title="Cone Flower"></a>
<a href="macros/slides/6.jpg" rel="lightbox[macros]" title="Pure White"></a>
<a href="macros/slides/7.jpg" rel="lightbox[macros]" title="Respledent Demise"></a>
<a href="macros/slides/8.jpg" rel="lightbox[macros]" title="Center Petals"></a>
<a href="macros/slides/9.jpg" rel="lightbox[macros]" title="Peach rose"></a>[/code


Remember, each image must have the [xxxxx] to get the tabs. And the first and last images in the set only have 1 tab not 2